[Testing] Testing Summary: 10 March 2012 - Auckland, New Zealand

Tabitha Roder tabitha at tabitha.net.nz
Sun Mar 11 04:51:36 EDT 2012

au196 on XO-1.5 summary (details below):
* Music Painter problems reported previously are (now?) intermittent
* Font in Terminal is still too big
* Chat is very chatty on the network
* ARP requests do not wake a laptop from suspend-resume
* Regular “mdns” broadcasts keep waking laptops up

os29 on XO-1.75 summary (details below)
* ARP requests do not wake a laptop from suspend-resume
* Google Docs on Browse seems much more stable if suspend-resume is turned

Rachel did some work on the testing pages on http://wiki.laptop.org and we
also tested Analyze_Journal and Sin diente (details below).

Music painter v9 on XO-1.5s running build 196 for Australia. Found it
intermittently does not work. Note that Ivy and Rosella are production
XO-1.5s and Tank is a prototype.
We tested on Rosella (firmware 22), Ivy (23) & Tank (22). On 3 iterations
of shutdown, startup, start music paint as new, Music painter:
* worked on Rosella twice
* worked on Ivy twice
* never worked on Tank
Our n of 3 is not big enough to show that the failure rate of Tank is
statistically different from the other 2.

Record on Rosella - can take pictures and long movies at high res, did not
test audio nor audio on movies

Speak on Tank - don’t see any issue with the tool bar.
Spirolaterals on Tank: seems to be working ok.
Terminal on Tank: Font still too big?
Physics on Tank: Still have the issue of when I draw lines that I see the
cursor trail but does not construct a line - this is when there are no
other objects there, so probably not a memory or buffer problem. Circle,
square, motor all seem okay.
Arithmetic on Tank: it is annoying that I have to wait for several seconds
after I enter an answer and it tells me it is correct before it goes to the
next question. Suggest the time restarts once the answer is labelled as
Tuxmath on Tank: tried to play but then realised my migraine is not letting
me add :).

Wake-On-LAN testing on XO-1.5 with au196.
Three laptops on Adhoc Network 11, 2 with power saving turned on and 1
without, for the most part no other laptops on this network.

We find that, when sleeping, the laptop does not respond to ARP requests,
we allowed a laptop to go to sleep and we pinged it from another laptop,
the first 15 pings were not sent due to no ARP information. It seems that a
multicast packet woke up the target laptop which then received the ARP
request. The following trace was made with tcpdump -p on the laptop that
went to sleep:

22:06:56.270776 IP > 0*- [0q] 3/0/0
(Cache flush) A, (Cache flush) SRV xo-a7-4c-2f.local.:5298 0
0, (Cache flush) AAAA fe80::217:c4ff:fea7:4c2f (129)
22:06:56.637739 IP > 0 [1a] TXT (QM)?
39adda6e at xo-53-5b-82._presence._tcp.local. (923)
22:07:31.022779 IP > 0 [2q] SRV (QM)?
39adda6e at xo-53-5b-82._presence._tcp.local. A (QM)? xo-53-5b-82.local. (77)
22:07:31.522639 ARP, Request who-has tell, length
22:07:31.522730 ARP, Reply is-at 00:17:c4:a7:4a:02 (oui
Unknown), length 28
22:07:31.527420 IP > ICMP echo request, id 1387,
seq 15, length 64
22:07:31.527567 IP > ICMP echo reply, id 1387,
seq 15, length 64

This behaviour seems to be the same on the XO-1.75 with os29.

If you join the network after chat is shared, chat does not show up in the

Chat sends a lot of network traffic, even when nothing is happening, there
is a multicast UDP packet sent every 2 or 3 seconds. With two laptops in
the chat these packets are 29 bytes long and seems to be some kind of
clique message:
22:43:01.403803 IP > UDP, length
       0x0000:  4500 0039 0000 4000 0111 9187 a9fe 06b0  E..9.. at .........
       0x0010:  efff 477f 3a8a 3a8a 0025 ec0e 436c 6971  ..G.:.:..%..Cliq
       0x0020:  7565 0103 fee3 cf85 02a6 c6dd f808 5e16  ue............^.
       0x0030:  eafe e3cf 856a bbc6 95                   .....j...

Joining a 3rd laptop to the chat causes all three laptops to send to the
multicast address, and the packets are now 37 bytes long. This explains why
suspend and resume is suppressed when Chat is running. This level of
traffic seems excessive when nothing at all is happening in the application.

We observed regular multicast “mdns” which caused the laptops to wake up.
We didn’t make a note of how often this happens, but it might have been as
often as every 45 seconds and was certainly more often than every 90

Google docs on Browse on os29 on XO-1.75 is much more stable if you turn
off the power saving. We’ll explore this further, including on XO-1.5 next

XO-1.75 prototype Bonnie visited a.sl.o using Browse - went to “just added”
activities. The first activity in the list is one with no ‘activity name’
visible on the website next to the activity icon (when downloaded to the
Journal it shows as Analyze_Journal) and the description says “This
activity gives you the possibility to graphically, the journal usage”. I
think it needs to say “... to graphically view the journal usage”.   When
opened you see a pie chart, which is really nice, but the labels are a bit
too small to make it easy to read. There is some information to the right
(info, total space, etc) but no corresponding numbers visible - it might be
off the screen or just missing. I wondered how to check the accuracy of the
pie chart for testing this activity. When you type df in terminal you see
76% of /dev/mcblk0p2 is used. I don’t know how to differentiate what part
is the journal. There is also  /dev/mcblk0p1 that says 20% used.

Sin diente activity on Bonnie
Some of the examples in Animals topic said “my body is long” but answer is
plural - serpientes.
Quite like the trivia about the animal when you get the name right -
however, there may be a better word for it than ‘significado’
(significance). Activity maintainer could consider changing to something
like ‘Did you know?’ or similar.
Strange phrasing on shark, ‘Y mi nombre doy a respetar’ - Do you mean ‘Y mi
nombre genera respeto’ or something of the sort.
Within four questions we started repeating.
The answer for ‘Tengo escamas y vivo en el mar’ is ‘pescados’ - Pescados is
the word for fish that have already been fished out of the water - those
still living in the sea are called ‘pez’ (plural: peces) This is actually
also what the ‘Significado says’ but - the correct answer to ‘vivo en el
mar’ (present tense) should be peces.
In the moral values section - the clue says ‘ cuando aceptas a los demas
tal y como son) and the answer is ‘respeto.’ meaning that until the period
was added to the end of the word it would not accept the answer was correct
- should the period be considered a letter? Same for ‘confianza’.
In the verbs category, a clue says ‘ Cuando estoy alegreme me gusta’. That
does not sound like correct Spanish grammar :)
We like what seems to be the ability to create questions oneself. This
shows up in the tab labelled ‘modo versus’ which I am not sure is
descriptive - I think the tabs are whacked - I think that pressing modo
versus sends you to the destination that should be of ‘Agregar lista de
palabras’ and pressing on ‘agregar lista de palabras’ seems to take you to
the destination of ‘Categoria personalizada’. Pressing on ‘caetgoria
personalizada’ takes you to a page that says: “no se ha imporatado ningna
lista de palabras ...’ that has no way of returning to the game and then
one needs to stop and restart the activity.
I love the ‘countries’ topic. In paises, the clue ‘world champion in 2010”
(yes, I know it is meant football, but being in New Zealand - land of the
long rugby history - I’d suggest the sport be named!) the answer is
España(with wiggly on the n) which the native English speaking player
pointed out
to the Spanish speaking player requires the player to know how to make ñ on
the keyboard and not all olpc keyboards have this written on the keys.
There is a learning curve here if the game is used to teach Spanish to
The answer for ‘sirve para informar y los mayores lo leen’ (I suggest using
the word adutos instead of mayores) - the answer is ‘el periodico’ which
uses the ‘el’ at the beginning, which is not required in other answers.
Overall, we liked the activity and enjoyed using it. The native English
speaker is slowly learning the basics of Spanish.

Rachel looked at the test pages on http://wiki.laptop.org/go/Tests after
Tabitha discussed
http://lists.laptop.org/pipermail/testing/2012-March/002629.html and
started trying to clean up. She says: The current
http://wiki.laptop.org/go/Tests page contains many subpages. These contain
potentially useful information, although the long pages are hard to
navigate. I have amalgamated all the Calculate tests under a new page:
http://wiki.laptop.org/go/Tests/Activity/CalculateTests, and made a note on
all the old pages that they are obsolete. If we agree this is a good
strategy, I can delete the old calculate pages, and amalgamate the other
test categories.

Thanks testers
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.laptop.org/pipermail/testing/attachments/20120311/9d327d1e/attachment-0001.html>

More information about the Testing mailing list