[Testing] Testing Summary: 3 March 2012 - Auckland, New Zealand

Deepak Muddha deepak at laptop.org.au
Thu Mar 8 09:07:37 EST 2012

Here are the links for the defects mentioned against au188 build on XO-1.5

   - Speak’s toolbar is squashed: *http://dev.laptop.org.au/issues/1126*
   - Musicpainter on au188 still doesn’t work : *
   - Font in terminal on au188 still to big: *



On 3 March 2012 16:35, Tabitha Roder <tabitha at tabitha.net.nz> wrote:

> Testing Summary: 3 March 2012 - Auckland, New Zealand
> Who: Alana, Charlotte, Eliot, John, Fabiana, Oliver, Leslie, Tabitha, Tom
> This week we tested build "29 customized" on XO-1.75 and "188 11.3.1-au"
> on XO-1.5
> Broken in os29 on XO-1.75 (details below):
>    - Raised #11668 for record high quality video problems
>    - We had several XO-1.75s hang while idle
>    - Distance is still broken on XO-1.75
>    - Yum complains the rpmdb has problems
>    - wake-on-lan works well but prevents laptops from going to sleep,
>    power logs are attached
> Broken in au188 on XO-1.5 (details below):
>    - Speak’s toolbar is squashed, see photo on picasa
>    - Musicpainter on au188 still doesn’t work
>    - Font in terminal on au188 still to big
> Google Docs is still unstable on Browse on both builds but it’s better on
> Firefox 10 on au188.
> Last week we successfully installed a new wifi card in Tank, thank you
> Sridhar for sending it to us! Next week we’ll do Poppy Copy.
> Last week we tested au183 and among other things, we used Screencast to
> record some Physics. Screencast seems to make the display update somewhat
> jerkely. Encoding the resulting screencast took a long time and seemed to
> stop at 35%, I don’t know if it aborted or the progress bar was mesleading.
> Something appeared in the journal, but I couldn’t play it -- error could
> not determine type of stra3. - gstypefindelement.c(8-984) …. Can’t typefind
> empty stream. We will follow this up next week.
> With os28 and several times in the last few months, I’ve noticed that the
> wifi password window steals the focus but does not appear at the front,
> worse, clicking on other windows does not restore the focus to the
> front-most application. It appears to be an invisible modal dialog.
> Switching to it with alt-tab brings it to the front and everything returns
> to normal.
> os29 on Clyde:
>    - Physics- still does that lack of update thing when I draw a line - I
>    see the cursor line but no line is drawn. I don’t seem to have this problem
>    with the other shapes. The response time also becomes really really long if
>    there are too many shapes!
>    - Measure: waveform ok, fft ok. Tried sampling - I get the constant
>    waveform and then  every 30 seconds it appears to freeze but only for a
>    couple of seconds and then returns to the live stream. The sampled frame
>    appears to be recorded in the journal. This means that one cannot start
>    looking at the data until the experiment ends. It would make more sense to
>    let the captured image frozen on screen and replaced every 30 seconds so
>    children can do measurements on them or have a split screen. Can’t really
>    tell if increase amplitude (bar on the right) is actually working
>    - Paint: froze completely, with no screen refresh when switching
>    applications. GDB doesn’t seem to work, it found two threads, but claimed
>    both of them had corrupt stacks.
>    - yum complains
> Warning: RPMDB altered outside of yum.
> ** Found 1 pre-existing rpmdb problem(s), 'yum check' output follows:
> mesa-libGL-7.9-6.fc14.armv5tel has missing requires of
> mesa-dri-drivers(armv5tel-32) = ('0', '7.9', '6.fc14')
>    - When you install gcc you get kernel-headers-
>    while the running kernel is version 3.0.19. Aftering writing a simple
>    program in C with a couple of functions and loops, we find gdb behaves
>    normally on this .
> os29 on Sundance:
>    - Record - photo ok. audio ok, movie on low ok for the full 2 minutes
>    but quality very poor. Movie on high quality has noticeably slowed down by
>    10 seconds and eventually stops. Raised olpc #11668.
>    - Memorise 36 can play, create games save and play them- did not test
>    collaboration.
>    - Measure seems to work ok (same as in clyde).
>    - Typing turtle: seems to be working ok.
>    - Does not respond to shutdown through right click on cetral XO figure
>    in the ring
> os29’s Distance on Kid and Bonnie
> Still very broken as reported earlier in #11596
> os29 on Kid
>    - paint works - tested opening from journal and activity ring, tested
>    some tools
>    - record works - tested picture, can open from journal and activity
>    ring
>    - maze works
>    - fototoon works
> os29’s wake on lan seems to be working well, but prevents the laptops from
> suspending for very long. Two laptops on an adhoc network do go to sleep
> but wake up frequently, 5 laptops on infrastructure wifi with internet
> access don’t really go to sleep at all. Looking in the power log is
> difficult because it seems to be written only occasionally? It also doesn’t
> clearly explain that a wakeup is due to lan. Power logs are attached but we
> didn’t take care to record what was happening when. Would such a test be
> useful? My power log collector does not work on XO-1.75 :(
> au188 on Tank  XO-1.5 C2
>    - speak and robot works but the toolbar is squashed, see
>    - maze works (didn’t test collaboration)
>    - record works - high, low quality, video, audio and image tested
>    - memorize - tested preloaded games, created a game but couldn’t save
>    it so it is lost (very disappointing to lose your work, it’s not in the
>    journal)
>    - ruler works
>    - music painter - no sound or play button doesn't work - cpu usage is
>    now 100% and csoundxo is using it - as reported previously
>    - moon works
>    - clock works
>    - poll works. improvements - ability to edit the questions and
>    possible answers after you have saved it but before someone votes. good
>    that you can hide the results as people answer so not influenced by other
>    voters, would be good if you can view them without all votes being
>    collected, and would be good if you could change number of votes required
>    after voting has begun (so if you forgot to change from 20 you can fix the
>    mistake). would be good if you could export your graphs with the title and
>    column/row headers as images for use in portfolio or write to make reports
>    and presentations.
>    - arithmetic - did all levels and tested using addition and
>    subtraction with an 11 year old, seemed to work, teacher in the background
>    didn't like it as she didn't like the panic it created in answering
>    questions
>    - socialcalc - started entering data, tried to do some formatting and
>    got the spinning wheel of death on the cursor and data can no longer be
>    entered
>    - spirolaterals -  tested on an 11 year old, she got it pretty quick
>    with a bit of help, teacher likes this one and how you can experiment until
>    you figure out the pattern, the child is doing some thinking aloud
>    - system resources - what is the * for?
>    - feedback - where does this go? how do i choose between personalized
>    (american spelling) and anonymous submit? submitted something but don't
>    know what that did, I saw the pulsing icon in the top left corner for few
>    seconds
> We’re using Browse to do collaborative editing of the testing report in
> google docs, it’s not working so well. I’ve successfully done collaborative
> editing for about 3 hours on a different wifi network with a different
> document and different collaborators on an XO-1.75 with Browse, but
> consistently, the testing report eventually encounters a slow script
> warning and usually browse appears to freeze shortly after. This happens
> both on the XO-1.5 with the Australian builds and on the XO-1.75. Perhaps
> the slow script timeout is too long? Firefox 10 on Rosella (XO-1.5) seems
> to operate google docs a lot better than browse. Not only is it much more
> responsive but is much more stable. This isn’t an option on the XO-1.75
> because Firefox don’t provide an arm build for Linux (they do for Android
> but that does not help).
> Kind regards
> Tabitha Roder
> _______________________________________________
> Testing mailing list
> Testing at lists.laptop.org
> http://lists.laptop.org/listinfo/testing


*Deepak Muddha
Software Test Engineer
One Laptop per Child Australia*
M: 91 8897367762
E: deepak at laptop.org.au
W: **www.laptop.org.au* <http://www.laptop.org.au/>* <deepak at laptop.org.au>*
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.laptop.org/pipermail/testing/attachments/20120308/dbbb2568/attachment-0001.html>

More information about the Testing mailing list