[Testing] Testing Summary: 8 October 2011 - Auckland, New Zealand

Daniel Drake dsd at laptop.org
Sat Oct 8 08:42:02 EDT 2011

On Sat, Oct 8, 2011 at 11:05 AM, Tom Parker <tom at carrott.org> wrote:
> Who: Fabiana, John, Rachel, Tom, Vincent
> Testing os8 customised on XO-1.0 and XO-1.5 and XO-1.75

Thanks a lot!
I presume we released our candidate build 880 a bit too late for your
weekly meeting. Will try and do it sooner next time.

> Record still doesn't work on XO-1.75, we have firmware Q4B10, do the
> camera fixes in this build not yet make record work?

The photo functionality should work, but you'll need to upgrade to
candidate build 880 first. audio/video not yet (#11296).

> Measure still doesn't work on XO-1.75.

Looks like we don't have this in trac yet. Can you define "doesn't
work" more precisely? Fails to launch? Tickets welcome!

> Maze is now normal sized! And it rotates! But it probably shouldn't --
> in portrait mode it extends off the side of the screen and the controls
> don't rotate so it's very confusing.

Old bug, https://dev.laptop.org/ticket/8993
You could report this on http://bugs.sugarlabs.org if it's not there
already (can't check, it appears to be down)

> Rotate works generally but on the XO-1.75 graphics are very slow in
> anything other than normal mode. XO-1 doesn't seem to have a performance
> penalty for rotation.

Known problem, acceleration gets disabled in rotated modes. Added to
11.3.0 release notes.

> The floor in Physics is fixed -- it now appears at the bottom of the
> screen instead of below it.


> Browse works, but there are differences between XO-1 and XO-1.75. The
> 1.75 causes http://www.nzherald.co.nz to serve a mobile version, while
> on the XO-1 you get the normal version.
> I guess this is a poor user agent sniffer at the NZ Herald, I'm not sure
> if we can do anything at our end?

Thanks for diagnosing. I agree, please file a bug with the NZ Herald :)

> tcpdump on XO-1 and XO-1.75 in promiscuous mode prevents the network
> from working, running in normal (not promiscuous) works.

Interesting... feel free to file a ticket so that we have this on
record (although it won't be treated with high priority for reasons
you can probably understand!).

> WikipediaEN on XO-1.75 dies in the same way as it did in os7 but os8
> seems to be much much slower than in os7 -- it takes perhaps 1 minute to
> see the Energy page and a few seconds after that it dies with the X
> Windows error, no scrolling required. We reported this last week as
> http://dev.laptop.org/ticket/11295 This does not occur when you visit
> the same page on the real wikipedia in browse. The frame also gets
> confused about which programs are running when WikipediaEN dies.

I can't explain the difference between different OS builds (perhaps
there is a random element to this issue), but I've added this as a
known issue to the 11.3.0 release notes, thanks.

> In WikipediaEN on XO-1.75, some of the icons in the top menu bar are
> just grey, and switch to black if you mouse over them. This doesn't seem
> to be a problem on the XO-1.5.

I think Gonzalo is working on this?

> WikipediaEN allows you to open new tabs, but you can't close them.

Gonzalo, any comments?

> On XO-1.75 Paint 36 works but froze the whole laptop on exit. Nothing
> obvious in the logs. The canvas is just slightly too big for the screen
> leading to scroll bars. It's possible that it would fit if there were no
> scroll bars.

Is this reproducible?

> Up arrow on Chat 71 moves the focus to the menu at the top, down arrow
> does not let you get it back, tab does. 3 way collaboration worked well.

Please file a ticket at sugarlabs if this is reproducible.

Thanks for the exhaustive and detailed report - very useful as always!


More information about the Testing mailing list