[Testing] can't boot XO-1 from USB, doc needed

S Page skierpage at gmail.com
Mon Nov 7 19:12:50 EST 2011

I wanted to try 11.3.0 but my XO-1 prints scary JFFS2 warnings before
"Boot has failed, sleeping forever.".  (After four years, no more
olpc-update for me.)

I'd like to boot off USB and look at my XO-1's NAND filesystem. But
the wiki instructions for booting off USB[1] were out of date. I've
updated them to de-emphasize the .ext3.img that's no longer built, but
can't find instructions for what's in current builds. There have been
mail threads and bug reports on the subject, recently "11.2.0 XO-1
boot from USB or SD doesn't work for me"[2] which wound up providing
workarounds [3] without explaining how to get started. I think there
was a more recent thread but I can't find it.

* Can I jump through hoops to mount the JFFS2 .img and transfer its
contents (cpio?) to an ext3 partition?

* I created an ext3 partition named OLPCRoot and used
    sudo tar --lzma --numeric-owner -xvf /path/to/os883.tree.tar.lzma
  to extract the build's files.  But the tree doesn't have /boot ,
initrd, or actrd?!  That's probably why trying to boot from it gives
  ok boot u:
  Boot device: /usb/disk: Arguments:
  The attempt to load a boot image failed.
These files are deep within u:\versions\run\883\boot , should I be
providing special arguments or creating symlinks?

Also, people have written separate instructions for booting from
SD[4], but wouldn't the procedure be the same?

I promise to write up any explanations provided...

[1] http://wiki.laptop.org/go/OS_images_for_USB_disks
[2] http://lists.laptop.org/pipermail/devel/2011-August/033009.html
[3] http://dev.laptop.org/ticket/11233
[4]  http://wiki.laptop.org/go/Installing_to_SD_Card

=S Page

More information about the Testing mailing list