[Testing] [olpc-nz] Wellington Testing Summary - Saturday 27 February

Mikus Grinbergs mikus at bga.com
Wed Mar 3 22:31:01 EST 2010

>> Speak-11: XO-1 os802b1, trying to use the robot tab causes the sound
>> on the XO to totally disappear until reboot.
> You've used an old version.  Please try Speak-12 which is the current
> version for XO-1 os802b1.  It was released on 19th February.

Sorry, James - I disagree with the recommendation to use Speak-12.

Speak-12 is one of the new versions, where the Activity "calls home" if
not all of the prerequisites have been installed on the specific system
on which the Activity is being run.  For myself, I believe an OLPC ought
not to asume that an internet connection is permanently available --
that is, I avoid installing Activity versions which might "call home".

> I've tried to reproduce your problem, but the symptom did not occur.

Just now I (re)tested Speak-11 on build 802B2.  Selecting the 'Robot'
tab resulted in the "normal" interactive dialogue with the Speak
Activity's robot function.  I then typed 'bye' on the entry line in the
robot panel, and selected the 'Activity' tab.  I was able to enter
"normal" words on the entry line in the activity panel.  After I closed
Speak, I was able to play music using another activity.  Bottom line --
for me, Speak-11 on XO-1 802B2 worked - sound was not affected.

"Could not reproduce your problem."


More information about the Testing mailing list