[Server-devel] [XSCE] Fwd: [support-gang] XO tablet can not connect to XSCE server

Samuel Greenfeld samuel at greenfeld.org
Sat Nov 9 19:53:52 EST 2013

Two comments on this:

   1. It is possible that Android is looking for the DNS search path
   provided by DHCP that tells a client what suffixes to try.  Looking at the
   git repository the XSCE DHCP server may not currently supply this.

   I will look into this a bit when I get the chance.  The fix if necessary
   would be trivial.

   2. https://github.com/XSCE/xsce/blob/master/vars/default_vars.yml seems
   to imply that the default domain suffix is ".local"

   That is a definite potential bug.  While ".local" is reserved for local
   use, multicast DNS clients effectively have taken over this domain to the
   point that older networks which have .local DNS entries have run into a lot
   of problems.

   A network I used to use was like this so I've seen random failures to
   resolve things firsthand.

   See http://en.wikipedia.org/wiki/.local for more information, although I
   do not know of an alternative good practice besides leasing a public DNS
   domain name that you know will never be used.

On Sat, Nov 9, 2013 at 6:45 PM, Anna <aschoolf at gmail.com> wrote:

> If I'm having trouble with connectivity on a client, I'll try to go to
> in the Browse Activity and see if it resolves.  It
> usually does, even if http://schoolserver doesn't because something's
> borked up.  Here's the ifconfig of an ethernet wifi dongle connected to an
> AP:
> eth1: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
>         inet  netmask  broadcast
>         inet6 fe80::21c:49ff:fe01:427  prefixlen 64  scopeid 0x20<link>
>         ether 00:1c:49:01:04:27  txqueuelen 1000  (Ethernet)
>         RX packets 4  bytes 649 (649.0 B)
>         RX errors 0  dropped 0  overruns 0  frame 0
>         TX packets 0  bytes 6549 (6.3 KiB)
>         TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
> I booted up an XSCE I had been testing with recently and an XO-1 client to
> test with.  Yep, http://schoolserver and http://schoolserver.localresolved from the client.
> goes to the portal page, too, of course.
> Then I physically unplugged my "regular" AP so the XSCE wouldn't have any
> internet.  And http://schoolserver and http://schoolserver.local resolved
> on the XO-1 client.  Wanted to just make sure that was the case.
> But what about an Android tablet?  I barged into Tyler's office and pried
> the Kindle Fire out of his hands (literally, he was playing Angry Birds),
> connected the Fire's wifi to the XSCE, and it got  Opened
> the Fire's browser and tried to go to http://schoolserver.  Hmm, page not
> found.  Then tried http://schoolserver.local.  And that worked!  It also
> accesses the Moodle login page at
> http://schoolserver.local/moodle/login/index.php.
> So there appears to be something with the Android browser that doesn't
> want to resolve http://schoolserver.  So as Curt suggested, try it with
> http://schoolserver.local and if that doesn't work,
> Anna
> On Sat, Nov 9, 2013 at 4:17 PM, Seth Woodworth <seth at sethish.com> wrote:
>> I am pretty sure that is the IP address assigned to the
>> network, and not to any particular computer.
>> If the network mask is then the .0 address will never point
>> to a computer or service.
>> If the network mask is anything else, then I don't know what I'm talking
>> about.
>> On Sat, Nov 9, 2013 at 3:39 PM, Curt Thompson <curtathompson at gmail.com>wrote:
>>>  Just making sure.. have you also tried and/or
>>> http://schoolserver.local ?
>>> On 11/9/2013 12:31 AM, Adam Holt wrote:
>>> From: Nathan C. Riddle <nathanr333 at charter.net>
>>> Date: Sat, Nov 9, 2013 at 3:18 AM
>>> Subject: [support-gang] XO tablet can not connect to XSCE server
>>> To: Gang <support-gang at laptop.org>
>>> The XO tablet can not reach XSCE server.  Unregistered XO laptop does
>>> reach XSCE server (http://schoolserver or
>>> The XO tablet WiFi connects and receives IP address (
>>> from the schoolserver using its "browse" or Chrome.
>>> Error message that applies suggest can not find DNS, i.e, can not use
>>> local lookup.  The XSCE is not connected to internet.
>>> This seems to be a restriction on the XO tablet, so this may not be an
>>> appropriate question to ask here.
>>> Was hoping that  XO tablet(s) could work in MOODLE with created login
>>> account (which works with PC laptop and presumedly with ipad).
>>> Nathan Riddle
>>> _______________________________________________
>>> support-gang mailing list
>>> support-gang at lists.laptop.org
>>> http://lists.laptop.org/listinfo/support-gang
>>> --
>>> Unsung Heroes of OLPC, interviewed live @ http://unleashkids.org !
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.laptop.org/pipermail/server-devel/attachments/20131109/3b4fa73f/attachment.html>

More information about the Server-devel mailing list