[Server-devel] Best XSCE strategy for us in Pacific with XO-1.5 2GB Testing XSCE 3 on XO 1.5 2GB os855

David Leeming david at leeming-consulting.com
Mon Jun 17 16:12:01 EDT 2013

In the Pacific Islands we have at least couple of recent deployments. I have
been helping in the Solomons with a 200 XO deployment sponsored by a
regional bank. They only received the shipment some weeks ago. In Fiji a few
months ago, Ian Thomson supervised a larger deployment with the Ministry of
Education and a regional university (USP). It seems that in both cases, we
have been shipped XO-1.5s with only 2GB installed with release 11.3.1. I do
not know the history of that.


This is causing us a lot of headaches. The Journals become full as there is
less than 100MB free space out of the box. There are work arounds but it's
less than optimal. We can delete Wikipedia-ES that gives us an extra 100MB,
but then as we want to add our own favourite Activities that are not
included in the release, we end up with the same issue. It's a problem for
children and teachers, even if they are taught to manage their Journals - I
imagine it would be disruptive in class.


The above is really not an issue for this particular list but it is relevant
because we would really like to experiment with XCSE, which requires release
13.1.0 as the starting point. Now we see that we can't install 13.1.0 on the
internal drive because the os image is too large (see attached). We
understand that if we want the XOs to be upgradable, we can increase the
internal memory but (a) it would take 100+ hours to do so on all the several
hundred XOs, and (b) we understand that the compatibility of cards can be an
issue, even within the same brand. 


The option of installing it on an external SD card is interesting, and I am
going to try that. However, we want to add content storage too - so we'll
need a 32GB or 64GB card. Would be interested to know if anyone has tried
with such a sized card. If we can do that, and have the content stored on
the same card, it would be the best solution for us. 


The reason we are so interested in the XSCE is because it means the schools
would not depend on a single non-XO machine for the school server. We would
want a solution where it's easy to swap if something goes wrong. These
schools are very remote, and it will not possible to download large amounts
of data during installs etc, neither do they have sustainable technical
skills on hand. 


For these reasons the XSCE on a bootable external memory card is the best
strategy. As long as (a) we can use a 64GB card to include our content
storage and (b) that it will boot on any XO-1.5 2GB machine without any



David Leeming

Solomon Islands


From: David Leeming [mailto:david at leeming-consulting.com] 
Sent: Monday, 17 June 2013 8:58 p.m.
To: 'George Hunt'; 'David Farning'
Cc: 'Jerry Vonau'; 'server-devel'
Subject: RE: [Server-devel] Testing XSCE 3 on XO 1.5 2GB os855


Still trying to set up my XO-1.5 2GB ready for XSCE, which as per advice
requires the 13.1.0 release as starting point. 


I downloaded the 13.1.0 files as per







Copied to a newly formatted 1GB USB stick, and checked the zd file md5sum

Renamed the zip to fs1.zip


Tried it:


Fails as per attached. Renaming the fs1.zip as fs.zip makes no difference.


Tried on a 2GB stick, also reformatted. No luck. Firmware seems OK.


Something I am missing about the 2GB version of the XO-1.5 ???


David Leeming


From: George Hunt [mailto:georgejhunt at gmail.com] 
Sent: Friday, 14 June 2013 8:41 p.m.
To: David Farning
Cc: David Leeming; Jerry Vonau; server-devel
Subject: Re: [Server-devel] Testing XSCE 3 on XO 1.5 2GB os855


There were kernel problems with 11.3.1 which kept us from getting the XO-1.5
to become an XSCE.  It was only with the 13.1.0 release, that we were able
to get the network adapters to work properly after a reboot.


So I'm afraid that everyone will save a lot of time, and pain, in the long
run, if the install procedure is followed exactly.


We were not able to test adequately the offline install for subsequent XSCE
installations to have it be part of the 0.3 release. But for situations
where internet access is slow, and expensive, it is possible to use a USB
stick to transfer the rpm packages contained in the /var/yum/cache from the
first XSCE to the next one, and greatly speed up the install process. (And
if you leave a USB stick in the XSCE, during the first install, it is our
intention, and design, that the /var/yum/cache will be copied to that USB
stick during the install process on that first machine -- and then used
automatically on a subsequent install)




On Thu, Jun 13, 2013 at 10:31 PM, David Farning
<dfarning at activitycentral.com> wrote:

Hmm, that is an interesting point that we kind of took for granted.

Our goal with the 'reference' hardware and software is to provide a
known set of stuff which 'just works.' While other hardware, software,
and features might work... they have not been tested.

Maybe george or jerry have a good answer for you.

At the risk of carbon dating myself... I grew up in the era where my
nerdy friends and I drooled over the pages of 'Computer Shopper' for a
9.6 kbit/s modem. Auto Resume for stalled downloads was a life saver:)

Now, for simplicity, our testing involves reflashing everything to get
back to a known state. As you point out, that is probably not the best
assumption for low bandwidth areas.

On Thu, Jun 13, 2013 at 8:36 PM, David Leeming
<david at leeming-consulting.com> wrote:
> Sorry just realised the XO is only installed with 11.3.1 (os855)
> However, is it still possible to work around? It's not easy or cheap to
> download the os file.
> David
> From: David Leeming [mailto:david at leeming-consulting.com]
> Sent: Friday, 14 June 2013 12:28 p.m.
> To: 'server-devel'
> Subject: Testing XSCE 3 on XO 1.5 2GB os855
> Testing XSCE 3 on XO 1.5 2GB os855
> http://wiki.laptop.org/go/User:Holt/XS_Community_Edition/0.3/Installing
> I get as far as step 13, after the SD card (I am testing with an 8GB card)
> successfully configures.
> When I enter "bootstrap-xo" is replies
> Not an XO please run 'xs-config'
> Tried to do that but
> xs-config: command not found
> David Leeming
> Solomon Islands
> _______________________________________________
> Server-devel mailing list
> Server-devel at lists.laptop.org
> http://lists.laptop.org/listinfo/server-devel

David Farning
Activity Central: http://www.activitycentral.com


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.laptop.org/pipermail/server-devel/attachments/20130618/09fcc789/attachment-0001.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: 13-1-0-install-error.jpg
Type: image/jpeg
Size: 33034 bytes
Desc: not available
URL: <http://lists.laptop.org/pipermail/server-devel/attachments/20130618/09fcc789/attachment-0001.jpg>

More information about the Server-devel mailing list