[Server-devel] [support-gang] Attempting to upgrade XO 1.5 firmware. Says "activation lease not found"

James Cameron quozl at laptop.org
Fri Jul 19 22:49:17 EDT 2013

Indeed.  Here's my checklist for bringing an old XO back to life:

1.  charge the battery,

2.  upgrade the firmware,

3.  disable security,

4.  run the diagnostics,
    ok menu

4.  set the clock,

5.  install the operating system,

6.  clean the keyboard, touchpad, and display,

7.  tighten the screws, check the battery latch,

8.  test the wireless antenna,

Placed on the Wiki:

On Fri, Jul 19, 2013 at 07:29:07PM -0700, Nancie Severs wrote:
> Hi Kevin, Richard, James and all,
> You have probably solved this firmware problem already. But for future
> reference I have a suggestion.
> When reflashing to one of the newer builds; i.e., 12.1.0 or newer, be sure to
> use a fully charged battery and a plugged in power adapter when reflashing. The
> new builds will upgrade the firmware automatically if the battery is fully
> charged. If it is not, during the end of the reflash process it will say
> something like "cannot get new firmware" continuing to update with old
> firmware. If you are not watching the screen you might not see this.
> And, I always check the system date and reset it (from the root terminal per
> instructions on the Fix ClockWiki page) before reflashing. That has solved the
> "stuck on the grey dots" problem.
> Best,
> Nancie
> Nancie Severs
> OLPC Support Volunteer
> ━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
> From: James Cameron <quozl at laptop.org>
> To: "Community Support Volunteers -- who help respond to "help AT laptop.org""
> <support-gang at lists.laptop.org>
> Cc: XS Devel <Server-devel at lists.laptop.org>; Support Gangsters
> <support-gang at laptop.org>
> Sent: Friday, July 19, 2013 7:40 PM
> Subject: Re: [support-gang] Attempting to upgrade XO 1.5 firmware. Says
> "activation lease not found"
> On Fri, Jul 19, 2013 at 10:58:45AM -0400, Kevin Cole wrote:
> > Unfixable bug: I'm an idiot, sometimes.
> Nah, we're working on it.  ;-)
> > I don't know if it's typical, but I often find that the USB port on
> > the left side of the screen doesn't seem to work as nicely as the ones
> > on the right.
> > [...]
> > This time less, rushed than yesterday, and armed with suggestions from
> > the list, I tried the same USB thumb drive on the one of the USB ports
> > on the right, and voila: away it went on its reflashing.
> There _was_ a problem with older firmware, now fixed, which combined
> with certain USB flash drives (with embedded hubs), would cause them
> not to work in _one_ port on XO-1 or XO-1.5.
> Having reflashed to 13.2.0 with external power supplied, that problem
> should have gone.
> If not, you may have a damaged USB flash drive or port.
> --
> James Cameron
> http://quozl.linux.org.au/
> _______________________________________________
> support-gang mailing list
> support-gang at lists.laptop.org
> http://lists.laptop.org/listinfo/support-gang

> _______________________________________________
> support-gang mailing list
> support-gang at lists.laptop.org
> http://lists.laptop.org/listinfo/support-gang

James Cameron

More information about the Server-devel mailing list