[Server-devel] Error Installing XS 0.7 from USB: can't find image #1 on disk

Brian Ghidinelli brian at vfive.com
Sat Jul 28 16:03:13 EDT 2012

On 7/28/2012 12:20 AM, Sameer Verma wrote:
> I simply copied the iso to the stick and that worked. See step 4 here:
> http://lists.laptop.org/pipermail/server-devel/2012-February/005822.html


This worked perfectly for me - I think your notes should be added to the 
wiki as they are more detailed and more accurate for how XS 0.7 on a USB 
stick seems to work.

Interestingly, my OLPC XS 0.7 already had EPEL/wget/etc in the build so 
I don't know if your notes were more specifically installing OLPC over 
CentOS or not but I don't think those steps are required for the ISO 
that is currently published.

If you want to update the wiki with notes from my install coming from 

1. Got Rufus to create a bootable USB from the OLPC XS 0.7 iso: 
http://rufus.akeo.ie/  (FWIW, unetbootin did not work)
2. Made the USB from the ISO first
3. Copied the ISO to the root directory of the USB second (per Sameer)
4. Booted up Logic Supply AG150, followed all of the CentOS defaults
5. Followed the rest of the steps in the post above for running xs-setup 
and xs-setup-network.

The only USB-to-ethernet adapter I could get on short notice was Apple's 
designed for the Macbook air.  It was recognized without a problem by 
the AG150.

Thanks for all the help!  Kasiisi's server has been broken for awhile 
now and I'm ready to pack it up in my bag for Uganda on Monday.  Anyone 
know if I will get hassled for bringing a lot of computer equipment?  I 
figure saying it's a gift for a school should cover it but I've been 
shaken down in a lot of places so want to have cover stories prepared. :)


More information about the Server-devel mailing list