[Server-devel] XS 05

Jerry Vonau jvonau at shaw.ca
Tue Jan 20 12:43:06 EST 2009

On Fri, 2009-01-16 at 14:15 -0200, Martin Langhoff wrote:
> On Fri, Jan 16, 2009 at 12:12 PM, Henry Vélez Molina
> <henry.laptop at gmail.com> wrote:
> > Thanks Martin for you answer.
> No problem!
> > We have been trying to install the server via the "Kickstart", but that
> > happens when anaconda  to start  can not do it and the screen turns off.

Do you even get any kind of UI or does the install shut down with
"install exited abnormally [1/1]"?

> Hmmmm, I can think of some possible causes...
>  - your download was corrupt or truncated - check that the sha1sum of
> the iso is
>    $ sha1sum OLPCXS-0.5.1-dev03-i386.iso
>    eab0fd3596bbfca532eec51eb5e774cb00b25cd8  OLPCXS-0.5.1-dev03-i386.iso
>  - You are hitting a low mem condition while installing the
> selinux-policies package. How much RAM does the machine have?
> > We
> > tried the solution that is in the wiki-press tab and add "text" and nothing
> > happens. One of the ways that we return to the terminal is pressing
> > Ctrl+Alt+2, then Ctrl+Alt+1.

Sounds like your in the Loader or GUI part of anaconda.. 

> That can help if the problem is with RAM - I think you need to hit tab
> earlier -- before the graphical installer starts. There is a very
> early screen, as soon as the CD or USB stick is read - hit escape
> *there*...
> > Could be the GPU problem?
> Very unlikely to be GPU or CPU
> > What can be do in these cases?
> - Ensure the iso is good (with sha1sum), check memory, try to uyse the
> text installer.
> - Installing from USB is a bit less reliable - try with a CD
> - Try is to install a standard Fedora 9 on the machine - sometimes
> there are subtle incompatibilities there...
> > Is there another way to start the installation?
> Not really :-/
> keep us posted on your progress so we can help...;
Can you confirm that you have the OLPCXS-0.5.1-dev03-i386.iso, please


I have not run a full install for the latest xs-0.5, I ran an upgrade
from a prior 0.5 install... I'm thinking that this could be a
kernel/anaconda issue with the change in kernel headers for 2.6.27.


This would show up just as the partitioning is about to happen....

If this is the case I have a patched version of anaconda that I
re-rolled, for the missing CF card kernel modules, 

Along with one that fixes auditd.c, wouldn't build without it.

And the patch in my custom anaconda that doesn't copy stage2.img to RAM
when using a hard drive for the source. My version of these patches
apply cleanly against F9's anaconda version.

This rpm would need to be installed on the build system and added to the
main XS repo. I'm just at the point of testing, loader builds fine,
looks to install the modules when run. I'm re-rolling the installation
media so as mkimages adds the needed modules, so loader can install
them, then on to testing the partitioning....


More information about the Server-devel mailing list