[Server-devel] Fwd: Hoping for assistance with XS 0.5 configuration difficulties (ejabberd)

Daniel Bennett dantana at gmail.com
Sat Apr 25 13:17:41 EDT 2009

I just sent this to Reuben.  I have done some digging through the log file
and haven't seen anything useful.  Do I perhaps need to set the ejabberd.cfg
file to 5:debug instead of 4:Verbose?  i remember seeing something about
that inside it.
Unfortunately, we we haven't set up a GUI, web browser, or emailing
capabilities of any kind on the server itself so emailing the log file will
be a roadblock for me.  I haven't worked in linux for about 5 years now
until trying to tackle this project.  I'm relearning how to do basic things
like ls, pipe to less, and use vi for simple text edits.  Setting that stuff
up is likely to take a loooong time.  Is there anything specific I can do
offline to find what you're hoping for inside.  In writing you this email I
just recalled the existence of grep.  is there something I could grep for in
the log file and give you some feedback on it?

On  the subject of following instructions, there have been two of us working
on the server, sometimes one at a time so I can't guarantee that we've
followed them to a T, but we both believe that we have.  We've gone so far
as to rerun the initial scripts, recheck hostname, reset the acl lines in
ejabberd.cfg repeatedly, connect to the jabber server with 2 different
jabber clients (which has been successful, we've chatted back and forth
using our server.  We just can't access the admin inteface at, we keep getting 401 unauthorized), read
every wiki page that sounded remotely relevant, etc.

And we've been following hunches at each step so we have pulled some of the
instructions out of related pages from the wiki.

I've been careful to comment out all of the original lines in the
ejabberd.cfg file and mark all of my changes for easy resetting of each
segment to it's original state.  Which I've since done.  So theoretically,
the file should be in it's original state except for the {acl, admin {...
line that we added to give admin privs to our sample user.

But of course, I could have made missed something.  However, the server is
still working fine when we connect via 3rd party clients (pidgin pis), so I
don't think I've done anything critical...

Let me know if I should grep anything out of the log file for you.

Thanks for the help!

---------- Forwarded message ----------
From: Daniel Bennett <dantana at gmail.com>
Date: Sat, Apr 25, 2009 at 5:57 PM
Subject: Re: [Server-devel] Hoping for assistance with XS 0.5 configuration
difficulties (ejabberd)
To: "Reuben K. Caron" <reuben at laptop.org>
Cc: Michael Ishaku <michaelishaku at gmail.com>

Thank you for the quick reply and the hints.  I've cc'd Michael Ishaku on
this thread.  He's and I have been working on this issue together and he is
going to be administering the server once I head back to the states.

I've replied to your statements inline below to the best of my ability.
 Please take a look.

On Sat, Apr 25, 2009 at 5:19 PM, Reuben K. Caron <reuben at laptop.org> wrote:

> I am sorry to hear about all your difficulties. I'd like to work with you
> to get this to work.
> If you cannot enter the ejabberd web interface to setup the online group
> then XOs will not collaborate.
> I'd like to know about your hardware, 2 nics or 1?

We have one LAN card for ethernet, but have also installed a wireless
networking card for communication with Access Points.  That should work,
right?  I'm really no IT professional... :)

> I'm sure you have read through this but please be sure to follow this line
> by line:
> http://wiki.laptop.org/go/XS_Installing_Software#Initial_Configuration
> One particular point I'd like to make in the instructions is this:
> --->Set the hostname of the machine like this (until we fix bug 8983) by
> editing /etc/sysconfig/network to set HOSTNAME=schoolserver.example.org

contents of /etc/sysconfig/network:
"/etc/sysconfig/network" 2L, 50C

> -->and restarting.

We had this problem yesterday when we left, and when i arrived this morning
I had to turn the server back on (it had powered off overnight due to the
generator being shut down and the UPS running out of juice).  I'm fairly
certain that we tried rebooting a couple of times during the day yesterday
as well.  I'm certain that we used the command shell to: service ejabberd
restart       many many times both days.  This would cover the restarting,

> It is important to restart before moving on; otherwise, the ejabberd db
> will be intialized using the wrong domain.
> Is the bandwidth too limited to download the new 0.5.2 ISO? If yes, I'd
> recommend a fresh install, connect to internet, and then after install run:
> yum update. After an up to date install run through the setup steps.

I left the states on 3/23/09.  I believe that 0.5.2 was released on 3/18/09.
 This is the file name for the image I brought with me (and that we are
currently running: OLPC-School-Server-0.5.2-i386.iso
we could probably download a fresh image with 12/24 hours if it were really
critical, but I'd like to avoid that much waiting around if possible.

> It appears you have dived into the ejabberd.conf file. Good for you! But
> I'd like to note you shouldn't have to perform this. The linked directions
> have worked for me on many installs on much different hardware.
> Does the XS have a public IP address?

Michael works in the building where we are temporarily housing the XS and
when i asked him if it would be possible for me to access it remotely he
said that unfortunately the entire building is a sub-network of some kind
that is managed by University staff from a separate location.  We've plugged
our hardware into the LAN port here and it's found a local IP address of  That's how we've been accessing the interface.  Or, failing to access it
depending upon your take on the situation.

That all means no public IP address, right?

> Let's get this working :-)

Please, let's!  I'll probably head for dinner sometime relatively soon, but
come back and check mail an hour or so later if you have a chance to reply.

Thanks again for the help!

> Reuben
> Daniel Bennett wrote:
>> Hi all,
>> I am working on an unofficial 100 XO pilot project in Jimeta, Nigeria
>> until the end of the month and I've run into a wall configuring the school
>> server.  I outlined it on IRC before bringing it here.  Because of the time
>> difference and inconsistent internet connection, email is probably a better
>> medium for assistance.
>> I hope that someone can help.  I really need to move through this issue as
>> quickly as possible if we're going to have a working school server at this
>> deployment before Ieave town next Saturday morning.  There is much left to
>> do besides tackling the XS.
>> Thanks!
>> -Dan
>> dbennetthi all, I'm working on a deployment in Nigeria this afternoon and
>> we are having a tough time getting the XS jabber server web admin interface
>> to work16:05dbennettwe have managed to get it to prompt for a user/pass
>> combo which seems to require user at node.domain which in my case is
>> dan at schoolserver.lccnyola.org16:06dbennettif we get any part of that or
>> the password in correct, it just empties both fields of the prompt and waits
>> for new info. However, if we enter user at fqdn as I showed above and enter
>> the correct password then it accepts our input and the prompt disappears.
>> However, all it returns is a "401 Unauthorized" page16:11dbennettWe've added
>> the: {acl admin {user, "dan", "schoolserver.lccnyola.org <
>> http://schoolserver.lccnyola.org>"}}. line to the access control list in
>> /etc/ejabberd/ejabberd.cfg16:11dbennettWe are running XS 0.516:13dbennettWe
>> are able to connect to the server with multiple users via jabber clients
>> like pidgin and psi. However, we can't seem to get admin rights to stick to
>> any of the users. I also can't figure out if there are multiple types of
>> admin rights (rights to http://server/admin/) vs admin rights within a
>> jabber client (show all online users, etc)16:18 *** jg joined #olpc-devel <
>> http://www.mibbit.com/chat/#>16:18dbennettIf anyone can lend any insight
>> it would be much appreciated. This is my 3rd day working on this issue. I'm
>> learning more bits about ejabberd, but i've only got a week left before
>> coming back to the states and would like to have my local server admin
>> running a working school server before I leave. 16:52dbennettIf you reply to
>> this later in the day and I don't reply to your reply, PLEASE send your
>> replies to the email based version of this request sent to
>> server-devel at lists.laptop.org <mailto:server-devel at lists.laptop.org> as I
>> have only infrequent internet access, and no ability to use an external IRC
>> client from my present location. Thanks! -Dan
>> ------------------------------------------------------------------------
>> _______________________________________________
>> Server-devel mailing list
>> Server-devel at lists.laptop.org
>> http://lists.laptop.org/listinfo/server-devel
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.laptop.org/pipermail/server-devel/attachments/20090425/263a1726/attachment-0001.htm 

More information about the Server-devel mailing list