[Server-devel] XS 0.5 Second Attempt at eth1

Anna aschoolf at gmail.com
Fri Dec 5 10:54:43 EST 2008

On Fri, Dec 5, 2008 at 5:04 AM, Martin Langhoff
<martin.langhoff at gmail.com>wrote:

> Anna, what's your NIC? Ideally, we want to know the marketing
> make/name/model and what lspci reports for it. Perhaps I can get my
> hands on the same hw you have.

I'm currently testing on two machines.  They're both circa 2003 Dells -
GX270 P4's.

Server A
02:09.0 Ethernet controller: D-Link System Inc RTL8139 Ethernet (rev 10)
02:0c.0 Ethernet controller: Intel Corporation 82540EM Gigabit Ethernet
Controller (rev 02)

Server B
01:07.0 Ethernet controller: Macronix, Inc. [MXIC] MX987x5 (rev 25)
01:0c.0 Ethernet controller: Intel Corporation 82540EM Gigabit Ethernet
Controller (rev 02)

Of course the Intel NICs are the onboard ones.  I found the other two in my
"junkyard," so more than likely they're circa 2000.

What's your other NIC? If you run xs-swapnics (and swap the cables
> too), do things work better with the bonding configuration we're
> shipping?

I tried xs-swapnics on both boxes during my first installation attempts, so
I know all four have had the different roles at some point.  I've moved the
D-Link to different slots in Server A when it was assigned the eth1 role.
I've tried using different cables; tried with a hub and without; and tried
getting an IP with an AP, a Fedora Desktop, and an Ubuntu desktop.  I think
I've been rather thorough.

So based on all that trial and error and messing around, I think I can
definitively report that I can not get bonding to work with any of my

I sure hope it's not an issue with the Dell GX270, because our deployment
got hold of a couple dozen of them to use as XS's.

Anna Schoolfield
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.laptop.org/pipermail/server-devel/attachments/20081205/70c8d5d9/attachment.htm 

More information about the Server-devel mailing list