[OLPC New Zealand] Testing Summary: 14 January 2012 - Auckland, New Zealand

Tabitha Roder tabitha at tabitha.net.nz
Sat Jan 14 06:19:19 EST 2012

Testing Summary: 14 January 2012 - Auckland, New Zealand
Who: Carlos(Naz), Fabiana, Lazar, Oliver, Rob, Tabitha, Tom, Trevor

We tested os24 on XO-1.75, os3 on XO-1, os883 on XO-1 (briefly) and au84 on

Testing os24 on XO-1.75 Sundance, Clyde and Kid:
We had Sundance lock up three times such that the only thing that worked
was the power button (which worked normally). Every time while using write.
Once inserting a table and, once after inserting a table and an image, and
again after inserting an image and then resizing it.

The Google search box in browse leads to a message from Google complaining
that the computer or network is sending automated queries instead of the
results of our search. This has been this way for some time I've only just
remembered to report it.

Distance doesn't work on XO-1.75, with two laptops approximately 30cm
apart, the distance reported varies between 40 and 90m. Distance on os883
on two XO-1 laptops works well in the same environment. Using distance
between an XO-1 and an XO-1.75 leads to even worse results than with two

Clyde XO-1.75 B1
Paint - works
Help - works
Moon - works
Implode - works
Maze - works
Clock - works *changed to Auckland timezone in laptop settings successfully
Stopwatch - works
Physics - works, wishlist - anticlockwise motor, presets like pendulums
Tamtam mini - works
Measure - works (didn't do much testing though)
Memorize - works
Record - no sound output, crashed once in video mode but could not
reproduce, did test high and low res video and images as well as audio
(which you can't hear playing back)
Distance - very wrong calculations of distance to another XO-1.75, issue
described above
Finance - works
Speak - works, robot can't answer any questions though
Labyrinth - works, image adding kind of breaks it, think using too much
memory? You wait and wonder for ridiculously long periods when you try
resizing or moving the image
Ruler - works
Terminal - works
Write - works
Fototoon - works
Portfolio - works

Sundance XO-1.75 C1
Paint - works
Tamtam mini - think there were some issues but mostly worked (think it was
this XO but they got moved around so might be wrong) - one key sticks and
sound plays continuously, and one key somehow changes you to the journal
Moon - works
Help - works
Clock - works *changed to Auckland timezone in laptop settings successfully
Stopwatch - works
Speak - works, robot knows its name (different to B1 XO-1.75)
Record - no sound output, can take high and low res video and photos as
well as audio, all save and can be viewed/playback without sound
Maze - works but hate the key combination on this keyboard (arrows are in a
row not in a triangle configuration)
Implode - works
Memorize - works
Measure - works

Testing os3 on XO-1s Twilight and Anna
We find that XO-1.0 Twilight and XO-1.0 Anna cannot communicate on adhoc
network 1 (created by the XO-1.75s) however they can both communicate with
XO-1.75 Kid. Both Anna and Twilight report destination host unreachable
when pinging each other, but both can ping and be pinged by Kid. Running
tcpdump causes interesting behaviour. If you ping Twilight from Anna,
running tcpdump on Anna does not appear to make any difference. However
running tcpdump on both Anna and Twilight causes Anna to recieve many
duplicate replies to her ping. Pinging Anna from Kid works normally until
you run tcpdump on Anna and then Kid receives duplicate replies to his
pings. See attached for pcap files. We had 5 or so XOs on this network and
you can see it was very chatty.

Testing au84 on XO-1.5 on Ivy:
This build seems to have an annoying "comic sans" default font.
When we ran out of battery, the laptop shut down as expected, but the power
light never flashed red.

Tam Tam Mini sometimes works. When it does work, it seems to be possible
record and endlessly play loop by mashing the keyboard. We're not sure if
this is a feature or a bug. The play/stop button seems to control whether
the loop plays but we were unable to work out how to use this feature on
purpose. Is there a hidden keyboard shortcut we are exercising? How do you
discover this feature?

Pressing the power button causes the normal three icon screen, and pressing
the power button again initiates shutdown but the laptop appears to froze
on the warning symbol screen. Pressing ctrl-alt-f1 f2 etc did not do

Deducto does not like the Australian font, the buttons at the bottom of the
screen are two small for the text they contain.

Colours failed to start.

Speak - robot knows its own name, how old are you get this response "I'm
... in human years", there are many questions where the robot leaves a gap
in its response for a missing word

Poll activity sort of works, but the "build poll" button doesn't seem to do
anything which makes the whole activity somewhat useless.

Thanks testers
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.laptop.org/pipermail/olpc-nz/attachments/20120115/23400220/attachment-0001.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: os3-ping.tar.bz2
Type: application/x-bzip2
Size: 27760 bytes
Desc: not available
URL: <http://lists.laptop.org/pipermail/olpc-nz/attachments/20120115/23400220/attachment-0001.bin>

More information about the OLPC-NZ mailing list