[olpc-nz] [Testing] Testing Summary: Auckland - 6 November 2010

Gary Martin garycmartin at googlemail.com
Sat Nov 6 19:20:23 EDT 2010

Hi Tabitha,

On 6 Nov 2010, at 10:58, Tabitha Roder wrote:

> Testing Summary: Auckland - 6 November 2010
> Who: Fabiana, Nevyn, Robin, Tabitha, Tom
> Write 73 on XO-1.0 build 18 customised Sugar 0.90
> When the drop down menus drop, they cover the first line of the document. (Is that also the case for other write activities?) It confused me since I thought I had lost what I had written. (Is this so in all versions?) -

Just to confirm, that is the intended behaviour for the new toolbar design. All new toolbars behave in the same way.

If you hover over a primary toolbar icon with a secondary palette (icons with a 'v'), the secondary palette will temporally appear without resizing the below canvas work area (resizing can be computationally expensive in some cases). The tools on the secondary palette can then be accessed; when the mouse moves out of the temporary palette area, it will auto close.

If you want to lock a secondary palette open for frequent use, single left click on its icon, it will resize/redraw the canvas and lock open, clicking the icon again will close it and regain the extra canvas space.


> Cannot test share over mesh since computers cannot see each other, they can over wifi, but even then they cannot share. can see icon in neighbourhood of xo that initiated the share, but it is not seen by other xo, does not work on invite either.
> Imported images, changed the settings of the image and it looks ok. Put images in table, and it looks ok. 
> Can copy image by right clicking and choosing copy, but cannot paste by right click menu, need to use pallette with scissors and paste through that. I can also paste the image with ctr-v.
> After pasting, I can undo with the undo arrow from palette but not by ctr-z. Ctr-z can undo text typing.
> Write 73 on XO-1.5 build Dextrose 373pyg
> Sharing works successfully with ad hoc networking between two XO-1.5s on same build. 
> XOPhoto 8 on XO-1.0 build 852
> On starting XOPhoto it exported some demo photos to the Journal but it wasn't obvious that it had finished. The progress bar completed but the cancel button remained. No photos appeared on the screen, even after pressing ok on the export progress bar thing. Quit and start new activity yielded expected behaviour with photos showing and a trash can. Created a new stack and added photos successfully. Used output play to view photos, changed timing successfully. To end the slideshow you have to push the small stop button otherwise when you change menus you still see slideshow not the stacks and trash view.
> Using help opens another sugar activity - this is a bit odd. The "home" button in help takes you to the top of the help page. Switching menus away from help closes the extra activity. We were wondering if this feature of opening and closing another activity would be useful for other activities, but couldn't think of any immediate examples. 
> Putting something in the trash and then clicking on trash icon gives extra icon for removing trash, gives warning, said ok. Checked Journal and confirmed the image is deleted from the XO. 
> Checked black and white in the sun. When you rotate you cannot see all the photos as it doesn't resize to fit the window. Found you could drag the photos into order in your stack. In the "all pictures" area, since I imported extra images I have found there are now blank spaces with no photos. Dragging photos around did not get rid of them. Tried dragging the empty spaces to the trash but that put other photos in the bin and the empty spaces stayed. I could trash some empty spaces but you don't see the coloured frame around them. We think that the spaces are images that it can't recognise, like we suspect one is a svg file. 
> Tried input - import from USB. Found it imports all pictures from USB, couldn't just choose 1 image (they appear grey). Imported jpeg, gif, png successfully. It created a "camera roll". Deleted camera roll and images stayed in "all pictures". Deleted a stack successfully. Tried to take images out and put onto USB, first time it failed, second time I created a new folder on the USB and then it worked. It created its own extra folder called "new stack" and put all the images from the stack I was in when I pressed export, success. After the export I thought I need to learn how to rename a stack, found it is possible from the activity menu.
> Couldn't see a collaborate option yet, but perhaps a future extension of this activity could be to have a way to create stacks together or share a stack (maybe "send to" a friend), for those with no USB stick, or a way to upload a stack to the school server to share with your class. 
> Turtle machine 7 on XO-1.5 build 5 customised Sugar 0.90
> This is very cool and discoverable. When it started getting harder we helped each other and quickly learned a lot. This will be a great lead up to Turtle blocks activity for young children and we enjoyed the patterns. We did 21 of 40 patterns. It would be good to make the patterns random after a while as we discovered you just increase each option by 1 to get the next pattern right for some sequences of patterns. 
> Adhoc networks with short names do not show up in the neighbourhood view on Dextrose os373pyg, see http://bugs.sugarlabs.org/ticket/2488 for patch.
> Tested SoaS Mango Lassi on virtualbox. Just booted the iso, didn't do the live usb or attempt installation to harddrive. The keyring dialog was very annoying, requiring many clicks before it stopped popping up. The Tamil translation seems to work a lot better than on Mirabelle (where it stops many activities including the journal from starting). The default screen size was too big for my netbook's screen, so had to scroll to see the top and bottom, virtualbox guest utilities would fix that i guess. Unsurprisingly, operation in virtualbox on an atom processor without virtual machine acceleration hardware is not recommended, boot time was very long on an Atom N280, and once booted was slower than an XO-1.
> Labels to print - 1x Mojo external, 1x Anna internal, 1x Monkey external
> Thanks testers
> Tabitha
> _______________________________________________
> Testing mailing list
> Testing at lists.laptop.org
> http://lists.laptop.org/listinfo/testing

More information about the olpc-nz mailing list