[OLPC-AU] Testing Summary: Auckland NZ - 19 March 2011

Tabitha Roder tabitha at tabitha.net.nz
Mon Mar 21 03:24:25 EDT 2011

Testing Summary: Auckland NZ - 19 March 2011

Testing au-861-2 on XO-1.0s
First problem is that this is the same version number as what we tested last
weekend but this was just released on Wednesday. Can all releases have their
own version numbers please to differentiate them?
Both http://download.laptop.org.au/XO/F11/10.1.3/XO-1/au2-rc2/ which we
might have tested last week and
http://download.laptop.org.au/XO/F11/10.1.3/XO-1/au2-rc3/ which we probably
tested this week have the same au861-2.img filename. We suspect that you
can't tell which you have once it is loaded on the XO but haven't
reinstalled an old one to compare.

Read the release notes but didn't know how to test what the release notes
also difficult to tell what has changed because there isn't enough
detail (eg activities have been updated, but no information on which ones)
and they don't seem to distinguish the releases either.

XOs automatically joined Mesh 1 so the following activities were tested on
Mesh 1: Speak, Write, Record, Music Painter, Paint, Maze, Physics, Memorize.

Speak still says it can't speak default lets speak English instead, there is
an sugarlabs ticket for this which I recall has been fixed. Basic test of
speak function, robot and audio chat. Audio chat didn't collaborate even
though we see the other XO in the frame.
Could speak be more polite? Would students notice? Can we change the opening
speech from "Hello X, type something" to "Hello X, type something please" or
Hello X, type something to begin"

Collaboration with two XOs successful. Good to see in this version of Write
the image and table menus are separate. Tested formatting and tables and
images. Ran out of memory or something on one of the XOs as its display
couldn't keep up with user actions (frame area went grey, text duplicates as
it tries to display the writing) and it couldn't write anymore or click on
menus or buttons but it didn't lose its connection to the other XO as could
see the other XOs contributions being added. Eventually it came right.

Successfully took some photos and made a video. Could not record audio (on
XO named Moodle). Tested on another XO and it could (on XO named Tux).

Music painter
Could paint the music on but couldn't hear anything when press play. Tried
with a headset too. Checked alsamixer. Tried restarting XO and it still
didnt play. Tried another XO and it still didn't work.

Did some drawing with pencil and brush. Added some shapes, changed colours
of fill and borders. Looked for a way to increase the border width and
cannot find it (last week I reported this and was told it is possible).
Added image, could move it around but not resize. Added text and changed
formatting. Grayscale effect worked.

Works, collaborated for a couple of games but then you could not see the
other player moving (they stay on starting square) though they still were

Still awesome. Need we say more.

Would be good if when you start a new game a different XO gets first turn
each time.
Tested addition, letters and sound games. Created own game with words and
images successfully.

Switched to local wifi. The following activities were tested on local wifi:

Could access websites by typing in the URL. Could follow links within
webpages. Can play flash videos. Could access sugarlabs activities page and
download and install activities.

USB test (for Sridhar)
Tested putting audio files onto a USB from one XO and then putting them onto
another XO from the USB. Mounted and unmounted on both XOs successfully.
File was readable. All seemed to work fine.

Power logs are attached. This release is in timezone "CST" which broke the
power log workflow as timezones seem to be very difficult in python. How do
I convert a string with a three letter timezone into seconds since the
epoch? I still haven't shared this script but the relevant code is:

    # WTF this doesn't parse 'Sat Mar 19 09:20:45 CST 2011'
    # laptopTZDate = datetime.strptime(dateString[6:-1], "%a %b %d %H:%M:%S
%Z %Y")
    # this only works for input in GMT
    laptopTZDate = time.strptime(dateString[6:-1], "%a %b %d %H:%M:%S %Z
    localTZDate = time.localtime(calendar.timegm(laptopTZDate))

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.laptop.org/pipermail/olpc-au/attachments/20110321/ee40cc9b/attachment.htm 
-------------- next part --------------
A non-text attachment was scrubbed...
Name: power-logs.tar.bz2
Type: application/x-bzip2
Size: 3372 bytes
Desc: not available
Url : http://lists.laptop.org/pipermail/olpc-au/attachments/20110321/ee40cc9b/attachment.bin 

More information about the OLPC-AU mailing list