[Etoys] finalStripping hangs waitForCommand

K. K. Subramaniam subbukk at gmail.com
Tue Jun 16 08:38:58 EDT 2009

On Tuesday 16 June 2009 04:52:29 pm David T. Lewis wrote:
> OSProcess relies on a semaphore to notify it when a child process exits.
> If you recreate the special objects array, it may be causing OSProcess
> to lose this connection, hence external processes would appear to never
> reach the #complete state.
> Try doing this immediately after recreating the special objects array:
>         OSProcess accessor initialize
> This will restart the process that waits on the semaphore, which will
> hopefully now be waiting on the correct semaphore.
I tried initialization in recreateSpecialObjects method just after the array 
got reset. The child semaphore became nil. I also tried it just after the 
Rebuild send. Ditto. log is attached.

BTW, should'nt recreate raise an event to other classes to get them to 
reinitialize their semaphores? or can OSProcess do a timed poll loop instead 
of a semaphore? Can we discuss this on #squeak?


-------------- next part --------------
A non-text attachment was scrubbed...
Name: SqueakDebug.log
Type: text/x-log
Size: 1791 bytes
Desc: not available
Url : http://lists.laptop.org/pipermail/etoys/attachments/20090616/7109d61d/attachment-0001.bin 

More information about the Etoys mailing list