[Etoys] Project loading trouble

Karl karl.ramberg at comhem.se
Fri Jan 11 04:00:56 EST 2008

Yoshiki Ohshima wrote:
>> The kind people at OLPC sent me a XO and the last week has been busy 
>> getting familiar with the system.
>   Cool!
It's a very nice machine. Quite a bit smaller than I had imagined. 
Keyboard only good for two finger typing :-) For my 5 year old daughter 
it is a nice size . I loaded some pdf on it to read in bed and that was 
very nice :-)
>> Anyway, I updated it to the latest dev 
>> build (1525) and can no longer load projects into the Etoys image. 
>> Anybody else experiencing this ?
>   Not really.  I'm also on 1525 and tried the examples in
> ExampleEtoys, projects from FileList, and also from Journal and all of
> them works.  Does it do something with non-ASCII file names or such?
> Can you explain a bit more?
Further investigation indicate a problem in the Journal. Each new 
attempt to load a project makes a new entry in the hierarchy of the 
journal linux directory with a other project I have stored. All attempts 
to load any Etoy project make a new entries with that other project. I'm 
a bit confused as most of the Sugar and Journal stuff is new to me. 
While the Journal is quite compelling in concept it leaves a few things 
to be desired. One is that associations to  activities is  quite hard 
to  change or make. That leaves the option to dig trough the obscure 
file hierarchy...

Anyway, I tried to update to joyride 1526 yesterday and it complained 
about some checksums or other issues and refused to upgrade, so it is 
something wrong with the whole system :-(

I have to figure that out first, and maybe the Etoy error goes away :-)


More information about the Etoys mailing list