intermittent keyboard mismapping: 13.2.5 on XO-1 SKU39

Adam Holt holt at
Mon Aug 3 19:03:44 EDT 2015

I haven't figured out the pattern yet, but perhaps 50% of the time these
XO-1s boot with an unusable keyboard (it's a "US Intl" keyboard, but the
keys end up mapped to all the wrong places, showing the wrong
letters/numbers, such that not even the ESC key works to get to the Ok

This pattern arises with "vanilla" 13.2.5 (without SD cards) as well as
13.2.5 with SD cards.  In other words both of these:

Running the "bye" command at the Ok prompt seems to trigger the problem
almost every time (possibly every time?).  But that is not the only thing
that triggers the problem.  Sometimes the XO just boots with unusable
keyboard, repeatedly.  Then when I try to hit ESC on boot 20 times in a
row, I cannot reproduce the problem at other times.  Problem occurs on all
SKU39 XO-1s I've tried so far.

I've not yet tried other SKU's.  My testing has only just begun, to see if
this same problem occurs with (both) 13.2.4 OS's and earlier.

Any tips for debugging / identifying the source of this quite serious
gremlin?  What should I and my small team of debugging volunteers look out
for and try?  And I'll do more work on this when I get back home late
tonight, but all thoughts appreciated-

(Also, any recommendations as to which older builds are best, as an interim
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the Devel mailing list