[Sugar-devel] XO4 touch stopped working (SOLVED)

James Cameron quozl at laptop.org
Fri Oct 25 18:37:02 EDT 2013

We are aware of a manufacturing process problem that caused what you
observed, but it was fixed some time ago.  We know exactly when it was
fixed.  When you give us the serial number, I can check if the laptop
was made before the fix or after.

The change you've made sounds reasonable, but it may not last.  Keep
monitoring the situation.

p.s. use the devel at lists.laptop.org mailing list for posts related to
XO-4 and unrelated to Sugar.  I've intentionally retained all of
thread below.

On Fri, Oct 25, 2013 at 03:19:52PM -0600, Juan Cubillo wrote:
> Tried the test /touchscreen and this message appeared:
> missing IR PCB
> failed to boot
> Tried the command again and a whole lot of code appeared (can't find my serial
> dongle so I can't copy it here)
> Tried the test for a third time and the message now was:
> missing IR PCB
> No touchscreen present
> I opened the screen and found that the conector for the ZIF cable was damaged
> and required some pressure to make proper contact. I just inserted some folded
> tape to keep it pressured and it's now working.
> No damage or mishandling was given to the laptop on my part so if there are any
> other reports of touch not working OLPC should stay aware in case the conector
> might be damaged from factory.
> Anyway... it's now working just fine :)
> Thanks for the info!
> Juan Adrián Cubillo
> Director de Tecnología | Fundación Quirós Tanzi
> Web: http://fundacionqt.org FB:Fundación
> Tel: (506) 2293-2460 ext211 | Cel: (506) 8832-1824
> On 10/25/2013 01:39 PM, Gonzalo Odiard wrote:
>     You can check the touchscreen from the bios:
>     * Start the xo
>     * While the startup sound is played, press ESC key
>     You will see a "ok" prompt.
>     * Type:
>     test /touchscreen
>     and press enter.
>     The screen will turn black and you can test it with until 4 fingers.
>     Gonzalo
>     On Fri, Oct 25, 2013 at 4:32 PM, Juan Cubillo <jcubillo at fundacionqt.org>
>     wrote:
>         Hello,
>         I recently received an XO4 touch to test. As far as I know, it came
>         with the default 13.2 Sugar image.
>         Last night I updated the system with yum update "just because". The
>         touch option stopped working but I just assumed it was due to the
>         update which might have broken some package or library.
>         This morning, I flashed the XO with OLPC's stable sugar build to
>         restore the XO and the touch option is still not working.
>         Is there any chance the update I made last night might have updated
>         something that broke the touch option? Some firmware maybe?
>         Also, is there any way to test if the XO is able to correctly detect
>         the touch hardware and test it?
>         I tried to search the mailing list and wiki for this but found no info
>         available.
>          - Juan
>         _______________________________________________
>         Sugar-devel mailing list
>         Sugar-devel at lists.sugarlabs.org
>         http://lists.sugarlabs.org/listinfo/sugar-devel

> _______________________________________________
> Sugar-devel mailing list
> Sugar-devel at lists.sugarlabs.org
> http://lists.sugarlabs.org/listinfo/sugar-devel

James Cameron

More information about the Devel mailing list