[support-gang] 1TB drive of quality open content on XO/XS--won't boot

Kevin Mark kevin.mark at verizon.net
Sat May 11 15:59:42 EDT 2013

 From: Holt <holt at laptop.org>
To: XS Devel <server-devel at lists.laptop.org>; Support Gangsters <support-gang at laptop.org>; Devel's in the Details <devel at lists.laptop.org> 
Sent: Saturday, May 11, 2013 3:44 PM
Subject: [support-gang] 1TB drive of quality open content on XO/XS--won't boot

Is there a way to boot a large USB hard drive attached to an XO?
The XOs (eg. XO-4 etc) refuse to auto-boot, leaving the screen at the OK prompt.
Does firmware currently block the mounting of all large USB drives -- NTFS in this case if not other filesystems?
Might there be a workaround so isolated XO servers in Haiti (etc!) can hopefully auto-boot with this quality free content?

My general impression is that NTFS being a non-unix FS(file system) is not greatly supported(which is not to say it has no support, but less than ideal) by linux(the kernel) and I'm guessing by the much smaller OFW there is even more limited FS options, so I'd guess it doesn't support it. So my view would be to format the drive with more likely supported FS like fat, ext2,ext3, ext4(not sure)?  
I'm not sure of the XO-4 issue. I'd expect an XO to look for a bootable drive (internal, external) and then some kind of network option. And it would fail if none were found and then show the OK prompt?  But there might be an issue that is related to attaching a usb-powered? usb drive at boot? See if it recognized by attaching the drive after the XO boot, if it does, then its related to the OFW FS support or some other boot issue.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.laptop.org/pipermail/devel/attachments/20130511/9c3b94fe/attachment.html>

More information about the Devel mailing list