Customization Sticks fails on 13.1.0 & 12.1.0 for XO-1 (Holt)

lionel at lionel at
Wed Mar 13 04:46:16 EDT 2013

Hi Adam,

I had a similar problem few month ago on 3 unlocked XO-1.5 on our
Saint-Denis deployment.
I've trace the issue with a serial adapter (posted here in a past mail) but
there is nothing special in the log.

I've finally fixed the issue in a strange way: enabling verbose boot with
"change-tag TS show" command on the firmware prompt.
See more  here:

It solve the issue, however there is two drawbacks to do that:
	- The boot is now very verbose!
	- You can't use a customization key when the verbose boot is enable.
BTW you could disable it just before using your customization key then
reenable it after.

Hope it could help.

One more thing: as a guy that had more than 200 XO to update by hand in Nosy
Komba this year. I'm very concerned and disappointed by the disappearing of
customization key. I can't imagine how we could deployed 12.1.0 and 13.1.0
without that!

Is there any complexity to maintain the customization key?

Best regards from France.



Date: Tue, 12 Mar 2013 23:16:22 -0400
From: Holt <holt at>
To: Devel's in the Details <devel at>
Cc: Support Gangsters <support-gang at>
Subject: Re: [support-gang] Customization Sticks fails on 13.1.0 &
	12.1.0 for XO-1
Message-ID: <513FEF86.9030309 at>
Content-Type: text/plain; charset=ISO-8859-1; format=flowed

On 3/12/2013 10:21 PM, John Watlington wrote:
> On Mar 12, 2013, at 3:54 PM, Holt wrote:
>> On 3/11/2013 10:08 PM, John Watlington wrote:
>>> Please don't redistribute secure laptops --- OLPC's policy since early
2009 has
>>> been to deprecate the security system.   The exceptions have been
>>> "large" enough to have dedicated support staff capable of handling their
own keys.
>> I wish :)  We have no choice but to continue to distribute secure laptops
in Haiti as these are Give1Get1 redonations that are already (largely) moved
from the USA to Haiti where the developer key process is
unrealistic+overwhelming to largely offline deployments.
> No more unrealistic than upgrading them.   All it takes is running a
> USB key over the laptops, mailing or emailing the small text file 
> generated to the US, and receiving a small text file back.

Hmm, we'll consider it but honestly when we head to rural Haiti
deployment(s) without reliable mail services for some one-time orphanage
deployment/update visits starting this wkd, the above might not work.

I supposed we could consider dev keys by text/SMS in theory?

Realistically I say far better to invite you down to carry them in by
motorcycle--Haiti's a shockingly beautiful, eternally misunderstood and
increasingly stable place--while Spirit's flights from the US remain not so
much more than last year's $59.

Early photos here:

Help kids everywhere map their world, at !


Message: 2
Date: Tue, 12 Mar 2013 21:34:45 -0700 (PDT)
From: Nancie Severs <olpc.dristi at>
To: "Community Support Volunteers -- who help respond to \"help AT\"" <support-gang at>
Subject: Re: [support-gang] New Builds vs Older Build: Need for
	<1363149285.76324.YahooMailNeo at>
Content-Type: text/plain; charset="iso-8859-1"

Hi all,
I'll try to keep my comments by subject on thread. 12.1.0 works very well on
the XO-1's. After testing 13.1.0 on XO-1's I have determined that 12.1.0 is
the best option unless like Adam mentions below, you need an Activity that
won't run on 12.1.0.

13 is too heavy for the XO-1.? 12.1.0 leaves approximately 100 MG more in
the Journal than 13. The Home View and switching screens (as I already
mentioned somewhere) is sluggish and irritating.) Activities are much slower
to load, leading to impatient folks like me, double pushing buttons and
freezing everything.

Re: 12.1.0 vs. 11.3.1, I like 12.1.0 especially because it automatically
names Journal entries in many cases. Perhaps 13.1.0 will get finished and be
better. Or perhaps the developer team will decide to clean up 12.1.0 and
make that the final build for the XO-1. In any event, it is probably a good
idea to keep the bug reports coming on both Builds.

I am reflashing a dozen XO's back to 12.1.0 from 13.? I'll also be updating
the additional Contributors XO-1s to 12.1.0 as time permits.

I agree with the post today. The XO-1's are still terrific and useful
laptops, especially with this Build.

Nancie Severs
OLPC Support Volunteer

 From: Adam Holt <holt at>
To: "Community Support Volunteers -- who help respond to "help AT"" <support-gang at>
Sent: Sunday, March 10, 2013 10:13 PM
Subject: Re: [support-gang] New Builds vs Older Build: Need for discussion

On 3/10/2013 10:02 PM, Adam Holt wrote:

For Haiti we reverted from Release 13.1.0 to 11.3.1 just today, in order to
get WikipediaFR to run, which sadly does not run on 12.1.0 and 13.1.0
>The slowness of 13.1.0 also became a decider (about 50% slower
      than 11.3.1 for most Activities/booting/etc, possibly due to
      Fedora 18, not sure?) anyway our training time in Haiti is quite
      limited, and we don't want frustrated teachers/mentors.
>Finally we strongly suspect something inside 12.1.0 and 13.1.0
      mangles the firmware causing most (all?) our unsecured XOs to
      never finish booting, after the 2nd boot at least?? Holding the
      checkmark (tickmark) gamekey every single boot is a workaround but
      annoying, this will trip up the classroom experience.? I suppose
      we could "relock" these unsecured XOs and it might fix the
      problem?? But we've run out of time to debug this flying to Haiti
      now, so sticking with 11.3.1 saves us the hassle.
Clarif, if someone's able to later solves this: unsecured XO-1's
    becomes permanently handicapped with this "Gray Dots Forever"
    syndrome, never fully booting into Sugar, no matter how many times
    you reflash back down to 11.3.1 it appears.
Installing 12.1.0 or 13.1.0 appears to be the trigger to
    "permanently" warp your unsecured XO-1.
Which is why we suspect something's badly buggy at the firmware
    level or similar?
Very sorry this is not a complete bug report, but many of us tried
    to face down this ugly nuissance over the last 10 days and failed,
    so we're steering clear of 12.1.0 and 13.1.0 on unsecured XO-1s
    until we know more anyway :}

Not sure if that helps you Gonzalo, but for Haiti, we really very badly
wanted the enhanced the new Sugar 0.98.2 experience that's part of Release
13.1.0 but had to decide against it this time, moving back to Sugar 0.94.1
part of Release 11.3.1, for now!.
>On 3/10/2013 9:08 PM, Gonzalo Odiard wrote:
>Concrete cases where we should improve are welcomed. 
>>On Sun, Mar 10, 2013 at 9:53 PM, Dr. Gerald Ardito
<gerald.ardito at> wrote:
>>For what is is worth, I have had the same experience was Nancie with
11.3.1 vs 12. I haven't tested 13 yet. 
>>>The XO-1s just seemed to work better with the earlier version. I would be
happy to document this more thoroughly, but wanted to add my two cents now.
>>>On Sunday, March 10, 2013 at 8:40 PM, Gonzalo Odiard wrote:
>>>Hi Nancie, 
>>>>Is very important for us (developers of sugar and some of the
>>>>know what problems you found or in what cases you think 13.1.0 is worst
than previous versions.
>>>>You can think is obvious, but the team is small and the job is big,
>>>>then we can do mistakes and sadly can't test all the combinations of
hardware/software, etc.
>>>>On Sun, Mar 10, 2013 at 6:15 PM, Nancie Severs <olpc.dristi at>
>>>>HI Adam and all,
>>>>>I told you so...(that the stuck at the grey dots is a significant
problem.) That bug needs to be identified and fixed.
>>>>>Re: 12 & 13 being slower than 11.3.1, and our discussion about whether
to use whatever build seems to work vs. using the latest builds (which
presumably fix bugs in the earlier builds and are thus better.
>>>>>The conclusion last week, was to upgrade to 13.1.0, so I have been
fully charging 8 laptops a day and reflashing to 13.1.0 to get them into a
"ready to ship" state. Should I stop doing that and leave 11.3.1 on
everything now? 
>>>>>BTW, I compared the free Journal space in the two builds. 11.3.1 has
350 MB free and 13.1.0 has 279 MB free. Now that the Journal deletes early
entries rather than showing "Journal Full," that's not necessarily a
problem. It depends what additional Activities and downloads are desired.
>>>>>Need for Discussion I think it is a good idea to make a decision as a
group, which final Build we would like to settle on. Any agreement, or
disagreement? I don't want to put 13.1.0 on Contributors XOs and then have
to reflash all over again.
>>>>>Thanks for weighing in!
>>>>>Nancie Severs
>>>>>OLPC Support Volunteer
>>>>> From: Holt <holt at>
>>>>>To: "Community Support Volunteers -- who help respond to "help AT"" <support-gang at>; Devel's in the Details
<devel at>; IAEP <iaep at> 
>>>>>Sent: Sunday, March 10, 2013 4:41 PM
>>>>>Subject: [support-gang] gray dots forever: when 12.1.0 & 13.1.0 never
fully boot (XO-1 especially? 11.3.1 too)
>>>>>On 3/10/2013 3:39 PM, Nancie Severs wrote:
>>>>>Going to 12 and 13, I am still getting a % of XOs that get stuck at the
grey dots when booting after the reflash is complete. Richard Smith figured
out that this is a Pretty Boot issue. He had a workaround that worked on an
XO 1.5, but I have not been successful had getting that to work on an XO
>>>>>I've the same issue with
                                              an XO-1 running Release
                                              11.3.1 -- it was
                                              previously running March
                                              6th's 13.1.0
>>>>>Now it freezes at the end
                                              of prettyboot (once all
                                              grey dots have formed a
                                              circle).? Sugar's
                                              interface never fully
                                              boots.? 2 workarounds
                                              (partially) force Sugar to
>>>>>1) Hold down the "check"
                                              game key
( on boot, or
>>>>>2) Hit the Esc key on
                                              boot.? Then type "boot" at
                                              the prompt
>>>>>As Nancie asks, how to
                                              force this every time on
                                              an XO-1?? Or perhaps this
                                              is not possible, according
                                              to "Enabling Verbose Boot from
OFW" at the bottom of:
>>>>>Hauntingly even if such a
                                              workaround exists, as the
                                              XO's main Power button
                                              does not respond as it
                                              should once Sugar has
                                              booted (short taps of the
                                              Power button are
                                              completely ignored when
                                              using the above
>>>>>Reflashing to 11.3.1 does
                                              not help, very
>>>>>I even tried reverting
                                              firmware from 13.1.0's
                                              q2f13 to 11.3.1's q2f11 at
                                              the ok prompt (this is an
                                              unsecured XO-1), and
                                              subsequent reflash to
                                              11.3.1.? But no dice.
>>>>>Nancie's getting something
                                              like 10-25% of her newly
                                              reflashed XO-1s ending up
                                              in this borked state
                                              recently, suggesting a
                                              deeper syndrome?
>>>>>Is there a pattern that
                                              many of these machines are
                                              unsecured?? That part's
                                              unclear.? FYI, I only
                                              wrote this up in case it
                                              hpoefully helps others, or
                                              someone has the antidote
>>>>>Interestingly: the
                                              9-month-old 11.3.1 appears
                                              substantially faster than
                                              13.1.0 on XO-1 in almost
                                              all regards.? Sad!
>>>>>Due to Fedora 14 to 18
                                              innards?? And/or Sugar's
                                              evolution from 0.94 to
                                              0.98?? O well.? Yioryos
                                              Asprobounitis has some
                                              time trial numbers here if
                                              anyone needs them.
Help kids everywhere map their world, at !
>>>>>support-gang mailing list
>>>>>support-gang at
>>>>>support-gang mailing list
>>>>>support-gang at
>>>>support-gang mailing list
>>>>support-gang at
>>>support-gang mailing list
>>>support-gang at
support-gang mailing list support-gang at 
Help kids everywhere map their world, at !
support-gang mailing list support-gang at 

Help kids everywhere map their world, at !
support-gang mailing list
support-gang at
-------------- next part --------------
An HTML attachment was scrubbed...


support-gang mailing list
support-gang at

End of support-gang Digest, Vol 64, Issue 38

More information about the Devel mailing list