Re-install os885 on XO-1.5 error

David Leeming david at
Thu Jun 13 01:28:48 EDT 2013

Thanks again James. 

The md5sum was OK so I reformatted the USB stick and tried again - and no
error. I have done this so many times before on XO-1 but never seen this. So
the first time I tried on XO 1.5 it happened. I must remember the old adage,
if the car doesn't start maybe it has no petrol...


-----Original Message-----
From: quozl at [mailto:quozl at] On Behalf Of James
Sent: Thursday, 13 June 2013 3:47 p.m.
To: David Leeming
Cc: 'OLPC Devel'
Subject: Re: Re-install os885 on XO-1.5 error

G'day David,

The CPU temperature of 54 celcius is a bit on the high side.  Please
run the heat spreader test on this unit:

	ok test /switches

If the heat spreader does not contact the CPU properly, the
temperature can rise too much during installation.  If the temperature
is too high, the CPU can pause, or make mistakes.

Significant gaps, blocks staying gray, are normal, and nothing to
worry about.  These blocks don't need to be written, so the .zd file
does not write to them.  This saves on downloads.

The error "Wrong expanded data length" means that the file was not
correct on the USB drive, or the USB drive could not be read.  The
task was aborted.  Things you can try:

* check the file using md5sum, see

* try a different USB drive,

* don't use a USB hub,

* disconnect any other USB devices,

* try a different port on the laptop,

* upgrade the firmware; you are using Q3C07, but Q3C08 contains a fix
for USB drives with embedded hubs, and Q3C13 has a fix for USB drives
with unusual partitioning.  Q3C15 is the latest version.

That the XO starts up OK afterwards is not a valid test, since it
would likely have the same build already installed.

No logs are kept of firmware operations, so you won't find any
evidence; you have to repeat the problem and gather data that way.

James Cameron

More information about the Devel mailing list