[OLPC New Zealand] Auckland Testing Summary 6 July 2013

Jerry Vonau jerry at laptop.org.au
Sat Jul 6 11:07:08 EDT 2013

On 6 July 2013 05:01, Tom Parker <tom at carrott.org> wrote:

> Auckland Testing Summary 6 July 2013
> Who: John, Tabitha, Tom
> Testing XO-system 1a For XO-4 (build 46)
> Sugar 0.98.7
> Firmware Q7B35
> Found that my previously described customization script was not working
> right -- the /etc/sysconfig/keyboard change is overwritten during first
> boot! Updated the customization script to also hack olpc-configure. Will
> look at options to do this better later.
The keyboard setting is read from the embedded data on the XO. No real need
to hack olpc-configure the OOB
the correct way of populating files as to avoid this.

> Found that this build does not include the Maori translations for sugar
> itself. Worked with CJL to get the language pack into the customization
> script. We’re not sure how we missed this as we have done a moderate amount
> of testing with Maori in previous builds, perhaps we saw the activities
> translated to Maori (activities are built differently) and just didn’t
> notice that sugar itself had no Maori.
Now that a fixed language pack is available, I will include it in the next


> The language selector is awful. It’s slow to appear, the drop downs don’t
> work the first time you use them and they scroll very slowly compared to
> the number of entries but too fast to easily spot your desired language.
> Sometimes when changing the language, when you click the restart now,
> nothing happens. If you click restart later and then restart the whole
> laptop the changes seem to take affect.
Some activities that we were expecting to be there, were not (maybe we are
> getting confused between builds prepared for different deployments). There
> is no GetBooks but there is Read (without any books!). There is also no
> Infoslice. There is no SocialCalc. There is no eToys.
> In Browse we went to activities.sugarlabs.org and tried to use the touch
> screen to write in the search but that didn’t work, you had to use the
> touchpad button to activate the search box. You also couldn’t just touch
> the button that starts the search, you had to use the touchpad button (or
> enter key). You could however use the touchscreen to select the activity to
> go to the activity page and touch to select download. Activities did
> however download successfully, install and run (like the Music keyboard
> activity btw).
> There used to be a menu on the left side of the homepage in Browse but it
> has gone on all the XO-4 homepages. You used to use that menu to access
> maps, images and sound files, as well as any published Infoslice activity.
> Maze works.
> Paint works well with touchscreen.
> Physics works well with touchscreen.
> Implode works well with touchscreen.
> Portfolio works.
> Measure works well with touchscreen.
> Labyrinth works.
> Write works and the Maori Macrons (now, after some changes) work. The
> insertion of a table changes the font to times new roman which is not
> actually a listed font available in Write.
> We’re not sure if there is a camera in the XO-4 SKU 303 serial SHC318001EC
> we just got from Australia, there is something there but it is at best
> mis-aligned. This laptop did get banged against a wall on it’s handle while
> it was closed. The direction of the impact was mostly parallel with the
> plane of the shut laptop and wasn’t too severe. Could this move the camera
> in the body of the laptop and also break it? Firmware camera test fails,
> record behaves reasonably (it only offers to record sound). Barry reports
> the second XO from the pair in this shipment has a working camera. The XO-4
> we got from Boston does recognise it’s camera on and it can take high and
> low quality video well. Will take photographs and wait for advice before
> opening.
> Moon still fails to start when the XO language is Maori. Previously
> reported in https://sugardextrose.org/**issues/3971<https://sugardextrose.org/issues/3971>
> Clock - loving the new grab hands feature, still doesn’t talk when XO is
> in Maori. Maori issue also reported in the same 3971 ticket.
> Labyrinth and Maze are both called Kōwhīwhiwhi - suggests an inappropriate
> translation of Labyrinth (guess it should be translated to a word more
> appropriate for brainstorm/mindmap activity).
> On some laptops terminal is called Terminal and on others it is called
> Kāpeka.
> WikipediaEN has not had an activity name translation either but this might
> be deliberate.
> Turtleblocks activity has a partial translation inside the activity due to
> new blocks being added. The name of the Turtleblocks activity has not been
> translated (but again that might be deliberate).
> _______________________________________________
> OLPC-NZ mailing list
> OLPC-NZ at lists.laptop.org
> http://lists.laptop.org/listinfo/olpc-nz
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.laptop.org/pipermail/devel/attachments/20130706/d1e53c7e/attachment.html>

More information about the Devel mailing list