OGV/Jukebox test summary: Re: 13.1.0 release candidate 3 (build 22) released

Mitchell Seaton mseaton at ekindling.org
Mon Jan 7 12:43:30 EST 2013

Hi all,

Since reading a recent blog post <http://www.olpcsf.org/node/120> by
Sameer, I was looking into TED video files and OGG (Theora) playback on XO,
I ended up testing with this latest release cand build 22 for 13.1.0 (Sugar

I have three test machines, XO-1, XO-1.5(HS) and XO 1.75. All have varying
results with playback of Ogg Theora video created with
ffmpeg2theora <http://v2v.cc/~j/ffmpeg2theora/> 0.29 on Fedora 17 (x64_64).
There are mixed results and general bugs with Jukebox (v29) also. I didn't
play around with conversion settings, used the same as in the blog post,
low video compression (lv 6) of sample TED low-quality (320x180) MP4 video
files. Playback tested in Jukebox (v29), Browse (v149) and Totem (Gnome).

Summary, files I created with ffmpeg2theora crash or have stunted playback
on XO 1.75, due to gstreamer 1.0 (F18 arm)?

Note(1), that I tested another Theora file (of Sameer's) created via
gtk-recordmydesktop ((wget
http://verma.sfsu.edu/projects/882-videos/intro.ogv)) and a web downloaded
OGV file ((wget
and playback was achievable on XO 1.75, 1.5 and 1.0 without any
errors/crash, except

Note(2), Browse (v149 or v149.4) crashes when trying playback any of the
Ogg Theora video files on 1.75 (as tested).

I can file bugs in SugarLabs <http://bugs.sugarlabs.org/>, have some
activity logs.

Jukebox (v29) issues:
A number of issues reported by humitos here  http://goo.gl/m082T
my observations
- XO 1.5, audio plays, but no video is displayed (blank/black bg)
- Play .OGV files from Journal (Journal/USB drives) and no video display on
startup for all models. Can get video after playing with playlist column.
- http://bugs.sugarlabs.org/ticket/3842 I also confirm, haven't tested some

Currently, Jukebox is not a good user experience for playing video, or a
playlist in Sugar. Other options still exist such as Browse (but fullscreen
button seem's broken on player widget) and Totem in Gnome desktop side.

Also final note(3) is I see a USB auto-mount issue on 1.75 machine, when
I've ejected the USB and reinsert again into a port. Without cmd-line, I
can re-mount by going to Gnome and selecting the drive. Didn't look into
any sys messages for this.

I also tried converting MP4 files to OGV on v27 of ffmpeg2theora on Ubuntu
12.10 x86 sys with same results for outputted OGV file.


On Thu, Jan 3, 2013 at 5:57 PM, Daniel Drake <dsd at laptop.org> wrote:

> Hi,
> We're pleased to announce the next release candidate of our new 13.1.0
> software release.
> Information and installation instructions can be found here:
> http://wiki.laptop.org/go/Release_notes/13.1.0
> Quick links for those who know which files need to be grabbed and save
> to USB disks:
> http://download.laptop.org/xo-4/os/candidate/13.1.0-22/
> http://download.laptop.org/xo-1.75/os/candidate/13.1.0-22/
> http://download.laptop.org/xo-1.5/os/candidate/13.1.0-22/
> http://download.laptop.org/xo-1/os/candidate/13.1.0-22/
> This is a signed release candidate that can be installed on all XOs,
> even those with security enabled.
> We're looking for testing and feedback on all aspects of the system.
> Thanks for any help you can offer, and for all the feedback that was
> received throughout development.
> Our scheduled release date is January 7th.
> Please review the "Known problems" section of the release notes. Some
> documented issues are carried over from previous releases, but others
> are new and are things that we will aim to fix in the few weeks before
> release.
> XO-4 automatic power management is disabled by default, but this is
> still a work in progress. There are still various instabilities which
> may make this build feel more unstable than eralier ones. You can
> disable automatic power management in sugar's Settings panel to
> restore previous behaviour.
> Compared to the previous release candidate, we have fixed:
> XO-4 sound output from some apps was previously just noise; this
> should now be better (#12366).
> Text on the XO-1.5 should no longer have missing 'i' and 'l'
> characters (#12354).
> The GNOME battery icon is no longer invisible (#12329) and is rendered
> cleanly once again on XO-1.75 (#12122).
> powerd's network activity detection should work again (#12430).
> New XO-4 firmware Q7B10 improves wakeup from suspend and includes some
> touchscreen improvements.
> Image rotation in Image Viewer works again on XO-1.75 (#12206).
> Thanks!
> _______________________________________________
> Devel mailing list
> Devel at lists.laptop.org
> http://lists.laptop.org/listinfo/devel

Mitchell Seaton
eKindling Technology Support
mseaton at ekindling.org
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.laptop.org/pipermail/devel/attachments/20130107/6554d169/attachment.html>

More information about the Devel mailing list