XO-4 not resuming after suspend

Gary Martin garycmartin at googlemail.com
Mon Feb 4 12:07:07 EST 2013

On 3 Feb 2013, at 22:04, Paul Fox <pgf at laptop.org> wrote:

> jerry wrote:
>> On Sat, 2013-02-02 at 09:25 +1100, forster at ozonline.com.au wrote:
>>>>>>> I have an XO-4 B1, OFW Q7B14, EC Firmware 0.3.10, os28.
>>>>>>> It won't resume after suspend, but sometimes it does. I couldn't
>>>>>>> reproduce the bug, but it happens most of the time.
>>> ...
>>>>>>> Anyone else seeing this?
>> I'm seeing this with my B1, hard lock just after suspending, can't
>> awaken the XO via any input method. Sorry no logs for this one. 
>>> For me, OS28 XO-4 doesnt seem to be going into suspend, mostly. It did suspend once and when it resumed it did not load the cursor, just a square of noise like a QR code, a bug we had in the early XO-4 builds. It seems suspend has regressed from OS27.
>>> Tony
>> I'm seeing this with the C2 unit I have, enabling powerd's tracing shows
>> suspend is being skipped with "cpu busy" once a rtcalarm wakeup event
>> occurs during until_dim-soft. I have the logs if needed.
> thanks -- yes, we've observed that something is consuming cpu
> on os28, preventing suspend.

Testing os28 on a XO-4 B1, and XO-4 C2: Interestingly if automatic power management is disabled in Sugar, My Settings, the backlight does start to correctly auto switch off when idle. With automatic power management on it is even preventing the backlight from powering off.


> paul
> =---------------------
> paul fox, pgf at laptop.org
> _______________________________________________
> Devel mailing list
> Devel at lists.laptop.org
> http://lists.laptop.org/listinfo/devel

More information about the Devel mailing list