Reflashing over a network

Jerry Vonau jvonau at
Thu Aug 29 06:26:51 EDT 2013

Hi James,

On Thu, 2013-08-29 at 18:19 +1000, James Cameron wrote:
> On Wed, Aug 28, 2013 at 08:53:33AM -0400, Tim Moody wrote:
> > I have been interested in this approach for some time, but was told
> > that the XO boot process that looks for a particular network name or
> > SSID is not implemented on recent XOs.  Bug or design choice, what
> > is the likelihood that this will be an option going forward?
> It was a bug.  It is now fixed.  It is 95% likely to be "an option
> going forward", but you must upgrade the firmware on XO-1.5, XO-1.75
> or XO-4.  See below for the upgrade.

Sorry I've known about the different behaviours since I've been
involved. Didn't know that it was considered a bug, just a reduced
feature set in favour of NANDBlaster is what I thought when I first got
involved. Didn't want to upset the apple cart.

> On Wed, Aug 28, 2013 at 03:52:46PM +0200, Tony Anderson wrote:
> > This is getting interesting but I am still not sure I understand the
> > process.
> > 
> > As I understand it, the XO will attempt to download the
> > 
> > (appropriately named)
> > 
> > and then the
> > 
> > os.img
> > 
> > from using http protocol.
> Yes.
> > However, this currently only works for XO-1 because of a bug in the
> > firmware.
> Yes.  The bug number is #12740, and the fixes are available in
> > There is an alternative via
> > 
> > boot net
> > 
> > which invokes a different firmware process that is working in all XO
> > models. This process uses tftp. The server would respond to a tftp
> > request from the XO by sending the and .img files.
> > 

Is tftp used just to retrieve the file? Is there a speed
advantage over http with tftp?

> No point, 'cause the time you waste getting a Forth program into the
> laptop is better spent getting the install data into the laptop.

The old recipe called for NN PP tags to be added that to OFW, not needed
if you use OLPCOFW now.

> Yes.  It works here, I just tried it with Q4D34JE with the web server
> on loaded with 32013o2.zd and
> would need to be available/aliased on the server for this as
that is coded as the default for the http transfer? In contrast tftp
would rely on the DHCP server for the server to contact and doesn't have
this limitation.

> > I can't seem to find /packages/obp-tftp on
In Lession 12 Automatic Net Booting refers to obp-tftp, I miss-took that
as a different/separate project, it's a sub-package build into OFW. 

>  I
> > suppose if we craft an olpc.fth script to setup the wifi networking
> > that could be used in place of the 4 button boot?
> I don't understand the question, sorry.

I'm was just wondering if we can override what is defined in firmware by
booting a usb flashdrive with the same commands that you would use for
initializing the wireless for example flashing of firmware. I mean
setting of the SSID(MM), wep/wpa(PP), that sort of thing. Much easier to
just configure an open access point with OLPCOFW.

> Here's what happens if the four game key boot method is used:
> In the absence of USB drive, SD card, or a nearby NANDblaster, the
> firmware will open the network, which means one of either:
> - initialise the USB ethernet device, or
> - associate with either OLPCOFW or the SSID identified by the NN tag,
> and then send an HTTP GET to asking for the file,
> which it then validates against the security system, before executing
> it as normal as if it had been found on USB drive.

I take it this would be for signed build only or can the image be
unsigned if the XO is unlocked? 

Thank you for the detailed explanation,


More information about the Devel mailing list