Completely disable buildt-in WLAN

Jerry Vonau jvonau at
Tue Sep 25 13:25:09 EDT 2012

On Fri, 2012-09-21 at 13:56 -0400, Kevin Gordon wrote:
> On Tue, Sep 18, 2012 at 7:12 PM, <kgordon420 at> wrote:
>         Well then.  Silly me assuming it would be called libertas, or
>         usb8xxx ;-). I'll try that when I get home.  Thanks, KG

Hi Kevin,

Can you please test with both interfaces enabled then with a wired
adaptor and note the results? While testing the XS rpms for ARM at the
Toronto gathering we noted some very strange results when booting with a
second (wired) network adapter inserted in a USB slot. From looking at
the kernel boot sequence the USB bus looks to be found first and along
with its network adapter, resulting in the sdio adapter and the internal
wifi being found second. The udev 60-net.rules fires off for the first
interface the network adaptor is initialized as eth0. The internal wifi
is found second but wants to claim eth0 but the then gets stuck with
"rename3" in "/sys/class/net" and becomes disabled because the first
interface has already claimed eth0. The 70-olpc-net.rules can't rename
eth0 as it has already been assigned. Everything is fine should you
insert the adaptor after fully booting the XO, this only occurs when
(re)booting with the adaptor inserted. Before I file bug report can you
or someone else on this mailing list confirm our observations? Just got
back from Toronto and I think have a handle on that issue when it occurs
but need some sleep first. :)


More information about the Devel mailing list