Attempting to re-purpose former XO 1.5 4GB microSD cards.

Kevin Gordon kgordon420 at
Sun Sep 16 14:52:13 EDT 2012


I am to understand that any upcoming m/b upgrade to an XO 1.5 will perhaps
come with an 8GB card, thus making the old 4GB card superfluous.  As such,
I figured I would run an attempt at repurposing them.

So in anticipation, I've taken out two (working perfectly) microSD 4GB
cards from a couple of test 1.5's, placed 8Gb cards in the machines,
re-flashed them, and all is good on those XO boxes with the new cards

I then take the removed 4GB cards over to my Fedora 17 box and try to
reformat them.  I must be doing something wrong, or have missed some basic
info - and, no, I am in as su, and the cards are not in hardware read-only
switched adapters :-)

I've tried parted, fdisk, then tried diskutil over on a Mac, Ubuntu. and
yes, even disk manager on Windows.  I cant seem to find any way to delete
the 2 linux partitions and make just one big happy fat32 partition on
either card, on any machine, using any software. On Fedora, fdisk seems to
let me delete the partitions:  i choose, i delete 1 & 2, i write, i look
and it says there are no partitions.  But lo and behold, when I reboot as
suggested, they 'reappear'.  I even tried on an F11 and F14 box too.
gparted shows them successfully deleted, then on the post-op rescan,
they're back.    Am I missing something basic?  I have happily formatted
and reformatted, partitioned, resized, and otherwise intialised  many other
(non-former XO boot) SD cards with linux/fat32/linux-swap partitions on all
of these machines; but. alas I now feel all newbie again.


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the Devel mailing list