Regarding temporary ''pauses'', perhaps due to using an SD card with an XO

forster at forster at
Sun Oct 14 03:51:54 EDT 2012

I too have noticed pauses on my 1.5 and they are worse than they used to be. The mouse cursor is still active during the pause.


> I too have observed increasingly often "pauses"
> on my XO but have had no idea how or where to
> start to debug the problem.
> One thought I had is that the swap file on the SD
> card is the source of the problem (somehow) but
> I still have the pernicious/persistent hanging even
> without using the swapfile.
> I'll try with a brand new 16GB SD card to see if
> that helps.
> --Chris
> On 10/13/12, Mikus Grinbergs <mikus at> wrote:
> > Lately there has been discussion about using an SD card to expand the
> > "storage" capability of the XO.  [For instance, discussion of when an XO
> > functions as a server, having it keep its database on an SD card.]
> >
> > What I want to mention is that I experience occasional "pauses" on my XO
> > systems (each has a "permanent" SD card, on which I keep Activities,
> > Linux executables, etc.).  I do not know what causes these "pauses", but
> > my best guess is the following (particularly since "pauses" often occur
> > during a CLI command that is "massively" accessing the SD card).
> >
> > My guess:   SD cards have an "embedded chip" which is responsible for
> > "wear levelling" the electronic components used to keep the data.  It
> > does this by internally 'rearranging' "which data block is physically
> > kept where".  I think this 'rearranging' action by the "embedded chip"
> > gets launched (when some 'internal' SD card thresholds are met) during
> > an I/O access by the (XO) host -- and this "rearranging" results in that
> > host's I/O access being DELAYED until the "embedded chip" is done.
> >
> >
> > I have not compared the "performance" (from the user's point of view) of
> > running an Activity "from the SD card" vs. running it "from the XO".
> > But I do have the impression that the duration of the occasional
> > "pauses" which I as a user notice while running "with the SD card" have
> > gotten LONGER as my XOs have migrated to using ever-larger SD cards.
> >
> > mikus
> >
> > _______________________________________________
> > Devel mailing list
> > Devel at
> >
> >
> _______________________________________________
> Devel mailing list
> Devel at
> _____________________________________________________
> This mail has been virus scanned by Australia On Line
> see

More information about the Devel mailing list