XO-1 update to 885

James Cameron quozl at laptop.org
Fri Jun 15 00:56:24 EDT 2012

On Thu, Jun 14, 2012 at 09:35:20PM -0700, Yioryos Asprobounitis wrote:
> With the opportunity of 12.1.0/os14 update in the one of my XO-1s, I
> also tried to update my F14 XO-1 to 11.3.1/os885 but I get `can not
> download update contents'
> Indeed rsync://updates.laptop.org/ does not list
> "build-885". Actually the only 885 build there is the for the
> XO-1.75.
> Gave it some time in case it pulls it after the request, but no
> result :-/

It pulls in at time of request, but you have to make the right request.

(I would not use online update with an XO-1 because the amount of
effort to make free space exceeds the time it would take to download
an installation kit.  But, please do test it if you can, and report
your results.)

You said you used updates.laptop.org via rsync to test for the
presence of a build.  updates.laptop.org uses rsync but is not an
ordinary rsync server ... while you can use the displayed list as
evidence of a build existing, you can't use the list as evidence of a
build missing.  This is because when a name is presented, it looks for
the build in another place.  You aren't shown that other place.

Given that the existing name for XO-1.75 is build-candidate_xo1.75-885
it is likely that the correct name for XO-1 would be
build-candidate_xo1-885 ... I've tried this, and got a suitably long
delay while the updates.laptop.org server unpacked the build, and the
response looks good.

So please try

	sudo olpc-update candidate_xo1-885


James Cameron

More information about the Devel mailing list