On XO-1.5 with 11.3.0/11.3.1 -- hang during shutdown?

Walter Bender walter.bender at gmail.com
Fri Jun 8 16:52:52 EDT 2012

On Tue, Jun 5, 2012 at 10:37 AM, Martin Langhoff <martin at laptop.org> wrote:
> Hi folks,
> the Dextrose team has been hunting a bug on XO-1.5, on their variant
> of 11.3.x ("Dextrose 3" or DX3), and they are pointing out that it
> could be a latent or unreported problem in 11.3.x series. It could
> also be a problem in their modifications.
> While they continue to investigate, it is important to hear whether
> anyone has seen XO-1.5s handing during shutdown, on the "Warnings"
> screen.
>  - It seems to affect some units, not all. So far it has been seen on
> 3 units with SN starting with SHC037 .
>  - Units affected show the symptoms 2 out of 5 boots.
>  - Seems to be related to umount of /home failing. Adding sync ; sleep
> 2; before umount seems to cure it; that's their current workaround.
>  - Their debugging adventures are documented at
> http://dev.laptop.org.au/issues/1033
>  - They will be checking whether the symptoms follow the microSD card
> or the motherboard, swapping microSD with a "good" unit.
> Why is this important? When the unit hangs during shutdown, it is left
> in a condition where it can overheat, potentially damaging the unit.
> The bottom line: have you seen this issue on XO-1.5 + 11.3.x? Even if
> ocassionally? Let us know, and join the bug-hunting party.
> cheers,
> m
> --
>  martin at laptop.org -- Software Architect - OLPC
>  - ask interesting questions
>  - don't get distracted with shiny stuff  - working code first
>  - http://wiki.laptop.org/go/User:Martinlanghoff
> _______________________________________________
> Devel mailing list
> Devel at lists.laptop.org
> http://lists.laptop.org/listinfo/devel

While I haven't seen the exact symptoms described here, I have seen
some problems here in Chachapoyas. XO 1.5s running 11.3.1. It seems
that machines that are running for quite some time with very active
use eventually hang. I grabbed some longs from a Browse session, which
seems to be the activity running when the crashes happen, but looking
at the logs, it seems to be something failing at a lower level. See

Also, at times, Restart fails to restart.


Walter Bender
Sugar Labs

More information about the Devel mailing list