usb8xxx firmware

Yioryos Asprobounitis mavrothal at
Mon Jul 9 02:06:49 EDT 2012

In a *non* olpc/fedora XO-1 build, liberates consistently fails to find the usb8xxx firmware after suspend/resume (error -2) though on boot, re-boot has no problem.
This does not appear to be a powered issue, and does not happen with the libertas-sdio of XO-1.5 (with identical user-space)

Thinking that might be a timing issue I tried raising the reset count in drivers/.../libertas/if_usb.c to 20 with no improvement.

Tried to see if I could stop firmware from unloading during suspend, similar to commit 92f590a for if_sdio.c, but could did not identify the relevant point (if present).
I was wondering if this might be related by any chance to the recent 3.3 kernel commits, 2b06ed6 and/or c079dc7?

Let me repeat that olpc builds (os17) do *not* have this problem, so this is almost "noise", but I would very much appreciate any pointers (maybe after the 12.1.0 release ;)

More information about the Devel mailing list