Error while generating build for xo-1.75 on an xo-1.75

Martin Langhoff martin.langhoff at
Thu Jan 19 19:40:29 EST 2012

On Thu, Jan 19, 2012 at 12:55 AM, Anish Mangal
<anish at> wrote:
> I deleted these packages from the OOB cache and tried after a while
> and it worked.

That's the right workaround for a silly bug... somewhere in imgcreate
libraries of the livecd-tools fedora package...

> However, shouldn't we check for rpm package integrity
> (content-type) while downloading via pycurl/libcurl and move to
> another mirror in case of corruption or inconsistent file-type?

Actually, it's easier: the code is downloading stuff with pycurl, and
ignoring whether pycurl gets any error. A simple check on pycurl http
status should be enough to retry or fail early, and avoid polluting
the cache.


 martin.langhoff at
 martin at -- Software Architect - OLPC
 - ask interesting questions
 - don't get distracted with shiny stuff  - working code first

More information about the Devel mailing list