Must just be my week for strange behaviour

Kevin Gordon kgordon420 at
Wed Feb 15 12:50:51 EST 2012

I'm fixing up about 5 XO-1s I bought from eBay, all with what appear to be
RTC issues.

4 all worked nicely, page fault error from the serial adapter console,
entered the select/decimal/set-time, they rebooted and re-flashed very well.

Alas, number 5, when I crank up the power, all that appears on the serial
console is a '+' sign, no pretty Forth message, no Page Fault error, just
that lonely arithmetic symbol.

Went back to a couple of the others and verified that serial adapter and
console still worked

Is there a possiblity that this one beast might have a different baud rate
or parity?  I didn't really want to try the o, let's say, 32768 different
combinations of values, if instead there is knowledge out there that this
is a recognized issue that indicates an SPI explosion or sumpin'  :-)

Again no real panic, I can always use the parts.


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the Devel mailing list