[TRANSIENT] Peer XOs NOT shown in Neighborhood view when Power Management is enabled

nitika.mail nitika at activitycentral.com
Wed Dec 19 03:33:30 EST 2012

Hi Samuel,

   Thanks for the clarification!

Would it be ok to raise a ticket for this issue?

Thanks and Regards,

Nitika Mangal
QA Manager
Activity Central: http://activitycentral.com

On Tue, Dec 18, 2012 at 11:46 PM, Samuel Greenfeld <greenfeld at laptop.org>wrote:

> It sounds like you are having issues with multicast packet wakeups, which
> have always been a bit of a sore spot.
> I presume you are using ad-hoc networking, and have not left the XOs
> idling to the point they shutdown their screen turns black and the wifi
> card is turned off (~20 minutes?).  If this is with a schoolserver it still
> could be a known issue but might be worth raising again.
> Wake-on-LAN behavior with the 8686 wireless card is not as reliable at it
> should be.  XOs need to wake up on multicast events to receive data
> (multicast DNS) about the network neighborhood, but need to clearly hear
> such announcements {i.e. no collisions with another data packet}, and
> sometimes don't get them even if the XO is awake.  In crowded cities where
> there are lots of access points and other computers nearby this becomes
> more of a problem.
> And since updates are only sent every few minutes, it could take quite a
> while for everything to get synched up, with things lost along the way.
> Schoolservers/Jabber servers use TCP connections, should be retrying at
> the TCP level, and should not run into these issues unless a XO went fully
> into suspend (black screen/etc.) with the wifi card off.  If a XO is
> connected to a schoolserver/Jabber it will not show ad-hoc users even if
> they are on the same network.
> The ad-hoc networking model definitely could be improved but I do not know
> if anyone has ever taken up that task.
> There are several tickets on the subject; I do not recall filing any
> against 13.1.0 yet though.
> On Tue, Dec 18, 2012 at 12:40 PM, nitika.mail <nitika at activitycentral.com>wrote:
>> Hi All,
>>    Peer XOs are NOT shown in Neighborhood view  when Power Management is
>> enabled.
>> Tested on 31016o2 OLPC Image (Build 16) on two XO-1.75's... one Touch and
>> the other Non-Touch. Following observations were made:
>> 1. Having connected both the XO's to a network, when neighborhood view
>> was seen on both the XO's, only one XO displayed the other in its
>> neighborhood view. The second XO was all alone in the neighborhood view.
>> 2. At some point, due to suspending an XO (or network re-connect), same
>> thing can be observed on either of the XO's
>> 3. When Power management was disabled and system rebooted, this issue was
>> not observed.
>> 4. This has yet been observed only on XO-1.75's.
>> If anyone has observed this issue, please do advise.
>> Also, does this call for raising a bug?
>> Thanks and Regards,
>> Nitika Mangal
>> QA Manager
>> Activity Central: http://activitycentral.com
>> _______________________________________________
>> Devel mailing list
>> Devel at lists.laptop.org
>> http://lists.laptop.org/listinfo/devel
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.laptop.org/pipermail/devel/attachments/20121219/25696f30/attachment.html>

More information about the Devel mailing list