Update error XO-1 883

Peter Robinson pbrobinson at gmail.com
Sat Apr 14 19:21:07 EDT 2012

On Sun, Apr 15, 2012 at 12:05 AM, David Leeming
<david at leeming-consulting.com> wrote:
> On Sat, Apr 14, 2012 at 11:40 PM, David Leeming
> <david at leeming-consulting.com> wrote:
>> Trying to install x11vnc on an XO-1 build 883
>> ...
>> olpc-f14/primary
>> http://rpmdropbox.laptop.org/f14/repodata/primary.xml.gz: [Errno -1]
>> Metadata file does not match checksum
>> Trying other mirror
>> ...
>> Error: failure: repodata/primary.xml.gz from olpc-f14: [Errno 256] No more
>> mirrors to try
>> I tried yum clean all, reinstalling and trying again, checking date is
>> correct, checking Internet connection is OK, nothing works - but I did
> this
>> successfully on another XO yesterday.
>>> You need to use the baseurl directive in the yum repo config file not
>>> a mirror one as it's not mirroed. Peter
> Thanks, if you please can advise how do I do that, and comment why it worked
> previously (several times up to now I have done this successfully) ...

I have no idea why it worked previously but the error says there's not
more mirrors to try which means yum isn't getting a mirror, given that
the rpmdropbox isn't mirrored it means that it's not using a baseurl
configuration for it. The various repositories are configured in
/etc/yum.repos.d/ and the various yum manual pages are your friend but
you'll find the config file is quite simple, there's a couple of
examples in that directory.


More information about the Devel mailing list