11.3.0 can have difficulties with wired ethernet adapter

Jon Nettleton jon.nettleton at gmail.com
Mon Oct 31 12:25:09 EDT 2011

On Mon, Oct 31, 2011 at 9:14 AM, Mikus Grinbergs <mikus at bga.com> wrote:
> Using os883 with q3b22.rom on an XO-1.5.  On first-time boot-up with a
> build, which interface gets assigned to the ethernet depends upon when the
> ethernet-USB adapter gets plugged in to the XO.  [If plugged in too soon,
> the wired ethernet gets assigned the 'eth0' interface -- which causes
> conflicts trying to use wireless.]

This is a known bug.  I don't know the bug number off the top of my
head.  It is a race condition between the usb ethernet and the
wireless renaming udev rules.  To fix this unplug wired ethernet,
remove /etc/udev/rules.d/70-persistent-net.rules and reboot the
computer.  Wait for the computer to come up and then plug in the usb
ethernet adapter.  This will allow the persistent rules file to set
wireless as eth0 and usb ethernet as eth1 and susbsequent reboots want
cause the race condition where usb ethernet grabs eth0 and then udev
hangs trying to rename wlan0 to eth0 which is taken.

> Further, with the ethernet-USB adapter plugged in, shutdown usually takes
> about a minute (while displaying the U/L warnings screen).  It appears that
> something regarding the ethernet is being timed out.

Haven't see this sorry.   Perhaps getting the device renaming and
persistent rules straightened out will fix it.

> [Also, since this summer the Fedora 14 NetworkManager has gotten aggressive
> -- it periodically simply disconnects my ethernet connection (so that it can
> scan for wireless signals ??).  My bypass is to stop the NetworkManager
> before connecting the XO to the internet using the wired ethernet rather
> than connecting the XO through a wireless AP.]

Have definitely not seen this.  NetworkManager will bring up both
interfaces if they are available.  Are you sure that NM isn't
connecting to wireless in a bad environment and causing the network to
hang because it is going out the wifi connection instead of the usb
ethernet?  Please open a ticket for this and we can get some NM logs
to see what is happening.


More information about the Devel mailing list