11.3.1 build 13 released for XO-1.75

John Watlington wad at laptop.org
Wed Nov 23 17:22:03 EST 2011

On Nov 23, 2011, at 4:00 PM, Paul Fox wrote:

> john wrote:
>> I also ran into the problem that suspends take longer than on
>> earlier OSs.   Frequently a three second wakeup has passed
>> before suspend completes.  Even a six second wakeup hangs
>> occasionally.   I added pgf's code to tell the kernel to abort a
>> suspend if a wakeup event has happened during the
>> suspend operation to my script, and it fixed the problem.
>> I then ran into the problem that os13 doesn't actually
>> suspend.   This appears to be related to EC code --- if it hasn't
>> updated the EC code it works fine.    Linux thinks it is suspending,
>> but the power light never blinks.   Also seems to relate to having
>> DC power provided.
> i think that EC thing may have been a red herring.
> it seems that the "pgf's code" you added may be the culprit. (i.e.,
> the code from http://dev.laptop.org/ticket/11416#comment:3)  i don't
> know what's going on, but if i run, or rerun, your script on a failing
> machine, i reliably get errors to the effect of "processes refuse to
> freeze after 0.00 seconds" (from memory).  if i run just a single
> rtcwake (timeout doesn't matter) _outside_ of your dortc script, that
> s/r works, and then i can start your script and it, too, works.  since
> powerd will do an rtcwake on its own if you don't kill it soon enough,
> some of your "successful" runs may have benefitted from that.
> so i have your entire testbed running now, mostly using that trick.  i
> did not have to set olpc-ols.0/high_lim to zero.

Thanks.  I've modified my script to call rtcwake once w. a long
wakeup, then to move into the fast cycle with the kernel aborting
suspend if the wakeup event overtakes it during suspend.


More information about the Devel mailing list