can't boot XO-1 from USB, doc needed

S Page skierpage at
Fri Nov 11 17:05:10 EST 2011

I wrote:
>> I'd like to boot off USB and look at my XO-1's NAND filesystem. But
>> the wiki instructions for booting off USB[1] were out of date.

I still can't boot 11.3.0 from USB following

James Cameron helpfully replied:
> I would use to boot from USB
> and investigate the cause:

That worked using boot u:\boot\olpc.fth , very nice! I tweaked your
F.S. test steps to:

 # cat /proc/mtd
 # mkdir /mnt/MY_XO_FS
 # mount -t jffs2 mtd0 /mnt/MY_XO_FS

(I updated the wiki page with all this)

at which point after about 15 seconds I get
 JFFS2 error: (1053) jffs2_build_inode_pass1: child dir "root" (ino
#340448) of dir ino #340447 appears to be a hard link

Yet the NAND flash contents look pretty good, /home/olpc, /versions,
etc.  `find -inum 340xxx` fails to find those inode numbers, but
  find: ./versions/run/af5b6blahblah: Input/output error
`ls` reports this directory doesn't exist. Unfortunately there's no
fsck.jffs2 , so this seems irreparable. I hope it's just hardware
rather than the "steps to free up disk space" that I vaguely recall
running before I last shut down.

> I would also make a backup using the xo-backup tool included on the Tiny
> Core Linux build modified for XO-1.

That worked, nice!
  % gtar -v --create --directory /mnt/MY_XO_FS/home/olpc \
     --file /mnt/sda1/xo_home_olpc.tar .

Thanks again! Now I'll install *without* using olpc-update for the
first time in years.

=S Page

More information about the Devel mailing list