[Techteam] 12.1.0 devel build 1 released, for XO-1.5 and XO-1

Kevin Gordon kgordon420 at gmail.com
Mon Nov 7 10:43:34 EST 2011

On Mon, Nov 7, 2011 at 9:59 AM, Martin Langhoff <martin at laptop.org> wrote:

> On Mon, Nov 7, 2011 at 9:41 AM, Peter Robinson <pbrobinson at gmail.com>
> wrote:
> > Yes, its coming to F17 as a feature, as I said previously, that
> > doesn't mean that Fallback mode is going away in F17.
> There's nothing in that discussion thread about keeping a knob to
> enable fallback mode. The title of the thread says it all.
> I was just going to send Ajax your build, I see you're one step ahead
> of me :-) -- one thing is missing -- instructions on how to install
> it, for someone who's gotten rusty (like Ajax who hasn't updated his
> XOs in a while). And the XO-1 install process is different with UBIFS.

I was fortunate enough to have DSD install an F17 build on an XO 1.5 when
in SF.

So, I'm up for anything you want me to test.  I downloaded the xo 1.5 files
from build.laptop.org

On a new XO 1.5, i just used the same proc  as previously for developer
build installs:

boot to OFW,  enter 'disable-security' to verify no wp tag so the install
doesn't scrub mu ability to boot back into ofw :-)
copy os1.zd4 onto a usb stick
insert usb stick into XO 1.5
fs-update u:\os1.zd4.

The 'f'ile updated only 1 chunk' message is back, which means one enters
'reboot', but otherwise things were actually copied correctly.
The firmware updated to Q3B22.
It booted with a transient black screen, brings up the little arrow, then
goes to sugar arrow and boots into the sugar home screen, but has a little
black square on the screen in the bottom left corner.
Switched desktop to gnome.  Pretty b/g image, no desktop icons:-)
Wireless connected in gnome
Switched back to sugar (using menu)
Switched bac to sugar, little black square is gone.
Wireless network persists on Sugar side :-)
Shutdown from sugar doesnt immediately shutdown.  Goes to text mode, seems
to go into a loop, then after about 2 minutes finishes the shutdown.
Subsequent startup in sugar now does the unexpeceted  full black screen
transition, and the little black square in the bottom left corner
Switch to gnome - being a fool, i cant find the shutdown icon, or an entry
on a menu.  So, I go to terminal, enter shutdown, it broadcasts a 1 minute
delay, message,  then shuts down.
Reboot brings up prettyboot, then does the black screen transition again,
and even on the gnome side, the little black square in the bottom left
That's about all the time I have this morning to play.
I'll try the XO-1 once I get home




I dont have an XO-1 with me, but I presume if it's ubifs, the files will
also be the same (i.e. os1.onu and os1.uim), adn one will use the
update-nand ofw command, instead of the jffs2 copy-nand command.  But, I'm
presuming that.  Will let you know tonight.


> > What is the state of merging out VIA driver back into mainline? That
> > would certainly help from the XO 1.5 PoV.
> That's for Jon to answer...
> m
> --
>  martin at laptop.org -- Software Architect - OLPC
>  - ask interesting questions
>  - don't get distracted with shiny stuff  - working code first
>  - http://wiki.laptop.org/go/User:Martinlanghoff
> _______________________________________________
> Devel mailing list
> Devel at lists.laptop.org
> http://lists.laptop.org/listinfo/devel
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.laptop.org/pipermail/devel/attachments/20111107/4cce3673/attachment.html>

More information about the Devel mailing list