olpc update

Yioryos Asprobounitis mavrothal at yahoo.com
Sun May 15 12:13:53 EDT 2011

--- On Sun, 5/15/11, Daniel Drake <dsd at laptop.org> wrote:

From: Daniel Drake <dsd at laptop.org>
Subject: Re: olpc update
To: "Yioryos Asprobounitis" <mavrothal at yahoo.com>
Cc: "OLPC Devel" <devel at lists.laptop.org>
Date: Sunday, May 15, 2011, 11:37 AM

On 15 May 2011 16:27, Yioryos Asprobounitis <mavrothal at yahoo.com> wrote:
> tried updating to os19 from os18 that eventually worked but only after failing irsync_pristine and irsync_dirty.
> specifically:
> $ sudo olpc-update 11.2.0_xo1.5-19
> Downloading contents of build 11.2.0_xo1.5-19.
> Updating to version hash c1ce32103b7d7c943dddc44edc64a4bd
> Trying irsync_pristine update from rsync://updates.laptop.org/build-11.2.0_xo1.5-19
>  - Fetching contents.
>  - Performing incremental rsync.
>  - Cleaning up (trac #5051)
> Verifying update.
> Contents manifest failure at line 319
> Last file examined: powerd.conf

This means that you modified powerd.conf by hand after installing
os18, is that correct?

Correct. But why should this result in the update failing?Would it be possible if a file that is not in the delta, is changed but the user  to be update or skipped during incremental rsync?Not that is important when bandwidth is available, but may be relevant in places where connectivity is at a premium. 
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.laptop.org/pipermail/devel/attachments/20110515/35e9eb3c/attachment.html>

More information about the Devel mailing list