11.2.0 successful XO-1 olpc-update, keyboard woes

S Page skierpage at gmail.com
Thu Jun 30 07:32:39 EDT 2011

XO-1 updating from 10.1.3 to 11.2.0.

It was hard to free up enough space. As Yioryos Asprobounitis said in
"olpc-update works on XO-1!" I had to delete ~/Library content and
there's no UI to do so for bundled content.  After I freed up enough
space, my third `sudo olpc-update candidate-870` completed
successfully, so it seems you can just retry the command until it
works. I don't know how much space free I would have needed to do it
one go, his 470MB sounds about right.

Shutdown and restart went fine, and then I had 370 MB space free
thanks to 11.2.0 removing the old version's files in /versions.
Software Update worked fine, down to 311MB free. Networking and power
seem to work well, Journal preserved my old items and metadata. Great

I had problems with the keyboard. Someone was saying in another thread
(that I can't find) that Shift+Ctrl+C/V don't work to copy and paste
in Terminal activity. I found this too, for hours only the menu items
worked. Then the keyboard shortcuts started working; it might have
been some combination of moving between various activity menus that
made it work.

Ctrl+Alt+Neighborhood to switch to console doesn't work, nor do other
Ctrl+Alt+Fn combinations.

Also, pressing left and right mouse buttons simultaneously used to
paste the primary selection in Terminal, I think because this
simulates a middle-click and that's been the middle mouse button
behavior in UNIX. Not any more.

When My Settings is up, if you Alt-Tab to the Journal you can't
operate the Journal or type in its find box, but you can Alt-Tab to
the Terminal and type behind it.

The Frame gained a new touchpad icon that seems to disable the
touchpad, I couldn't see any documentation for this in release notes
or Sugar release notes or the Help activity. Unlike everything else in
the frame it has no context menu on hover.

I can file bugs for these...

=S Page

More information about the Devel mailing list