Kevin Gordon kgordon420 at
Fri Jul 29 16:56:04 EDT 2011


Hello good sir:

I'm back from Kenya and ready to continue the troubleshooting on the SISUSB
front.  To reiterate:

1) on 11-2/874, my USB2VGA and USB2VGA2  adapters with external monitor
always works on a 1.5
2) on 11-2, any build, on an XO-1. out of 100 tries, system virtually always
'hangs'.  One of them booted up once - still didn't show a picture, but it
did boot.  Rest of the times they would hang at the v - one dot point or
three dot point of the animation
3) on 10-3/860 on those same XO-1's, the adapter and ext screen always
work.  What this tells my litle grey cells, is that a) it's probably not
firmware, since the firmware is the same on those XO 1's whether Ive flashed
them to 860 or 874.  and b) since it works on a 1.5, it's not an fc14
thing.  The devil is in the middle there somewhere :-)

I had left the XO-1 on after an attempted boot with the USB2VGA adapter
plugged in, yep two weeks.  When I got back there were a couple of udev
messages on the ctl-alt-F3 screen which I will forward to you if you think
they might be of value.  Mentioned upcoming deprecation of 'STAT' etc.  FYI,
I do all this work without doing any customiaztion.  These are vanilla,
virgin, 4-game key flashes using original images.  None of my deployment
funny stuff.   I did read that Sameer had been successful getting an XO-1 to
come up on 873; but he used olpc-update, so I might try that too, just to
see if maybe some working x thing is persisting that makes it all happy.

Since I forgot to do that little dump thingy you had asked me to  do before
sending the log from the serial adapter, I will do that over the weekend.

So a rather long introduction to short question: should I now be testing
these beasts using os1 on 11-3 instead of on the already released 11-2 ??

BTW all the machines at our Kenya deployments are running 11-2.  We will get
any issue reports and forward them up the chain.  There are anecdotal
complaints that the trackpads and keyboards are locking up more frequently
than on 802, and that certain build-provided activities that worked
flawlessly on 860, are doing a 'fail-to-start' on the first, second and
sometimes even once in a while on subsequent attempts.  However, all this is
currently anecdotal rather than scientific reports.

Last but not least, as you may remember, we do install some extra software
on the machines using yum --downloadonly while here in Canada to get the
RPM's to a USB stick, then in Kenya do a yum localinstall there to be more
efficient with teh sometimes slow, and always expensive data time.  On the
XO 1.5's, all goes well with everything installing nicely.  On the XO 1's, I
get a lot of '...was supposed to be installed but was not' messages.
However, it would appear that indeed the rpms did get installed.  The
google-verse seems to indicate this might be a permissions issue.  All the
software seems to run fine, and any attempt to reinsall sys 'Nothing to do'
as the package doesnt update the existing one.  Weird.  And, there is a
'RPMDB was modified outside of yum' message when subsequent installs are
tried.  Again everything seems to 'work' but the messages are a little
troubling.  Again, no such messaging on the 1.5's.

That's it from here for now.  I await your wishes on 11-3 versus 11-2 for
the USB2VGA.


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the Devel mailing list