Fixing yum on F14-arm build os31

Peter Robinson pbrobinson at
Thu Aug 4 03:30:05 EDT 2011

On Wed, Aug 3, 2011 at 10:44 PM, Martin Langhoff <martin at> wrote:

> On Thu, Jul 28, 2011 at 4:03 PM, Martin Langhoff <martin at>
> wrote:
> > The "Switch to Fedora-14" build.
> >
> > Download from:
> >
> >
> The default yum config - which we include - points to the official
> Fedora mirrors, and those don't really support unsupported
> architectures like ARM. Surprise!

Actually there is a means of this being supported when F-14 gets replicated
to the secondary mirrors. I'm working to get this to happen but there's a
few holdups.

> Of course it's in my list of things to fix. In the meantime, here's
> what you can do
>  - edit /etc/yum.repos.d/fedora-update.repo -- look at the first
> section, disable it (enabled=0)
>  - edit /etc/yum.repos.d/fedora.repo -- look at the first section,
> disable gpg checks (gpgcheck=0), comment out the mirrorlist line, and
> add
>   baseurl=
> You're done! Note that it is a partial repo, and it only has the
> packages at the F14 release time versions. Additionally, some packages
> are missing or tagged wrong.
> If you want a package that is missing, ping Peter to see if it'll be
> available soon.

Poke me on IRC/gtalk and its likely I can push it through, a few like csound
are being fun but we're getting there.

> If you see a package or dependency bail out complaining about
> python(abi)=2.6, let Peter know. The repo is just showing the wrong
> package (and the right one is likely there).
Poke me on IRC/gtalk. This one is a side effect of the mass rebuild script
due to the bump to python. Hopefully we'll past this one soon.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the Devel mailing list