[Sugar-devel] battery indicator missing on customized image based on 11.2.0 for XO 1.5

Jerry Vonau jvonau at shaw.ca
Tue Aug 2 18:01:14 EDT 2011


I haven't tried to remove gnome, but the one difference is the battery
applet rpm(batti) is being asked to be installed on the image in
modules/gnome/kspkglist.50.gnome.inc, which is no longer being included.
Sounds like batti should be in a kspkglist file in modules/powered if
sugar needs this rpm also. Perhaps you can add that rpm to your .ini
file, to have that rpm installed. Think you then would need to have
kspost.50.batti.inc run, to pick up the needed changes, maybe copy that
fle to modules/powerd/   


On Tue, 2011-08-02 at 15:02 -0600, German Ruiz wrote:
> Hello List
> I'm trying to create an olpc image based on 11.2.0 for XO 1.5 with
> some customization like (no gnome, new bootanim, adobe flash, extra
> activities, etc...), but i have one problem, when i disable the option
> for gnome desktop enviroment, the battery indicator is missing[0], i'm
> using the olpc-os-builder 3.0.0 on a fedora 14 desktop, has anybody
> seen this issue before???
> Thanks...
> [0]http://germanrs.fedorapeople.org/olpc-files/sugar_battery.png
> [1]http://germanrs.fedorapeople.org/olpc-files/olpc-os-11.2.0-xo1.5.ini
> [2]http://dev.laptop.org/pub/source/olpc-os-builder/olpc-os-builder-3.0.0.tar.bz2
> -- 
> German R S 
> _______________________________________________
> Sugar-devel mailing list
> Sugar-devel at lists.sugarlabs.org
> http://lists.sugarlabs.org/listinfo/sugar-devel

More information about the Devel mailing list