New XO 1.5 firmware with MPPT. Please test!

Richard A. Smith richard at
Thu Apr 7 15:22:49 EDT 2011

On 04/06/2011 03:18 PM, Ismael Schinca wrote:

> Hey Richard! Here's a log from a partial battery charge in the following
> conditions:
> - XO 1.5HS using the firmware you sent
> - Connected to an unregulated 10W panel
> - Using the script rtcwake-log you sent I think it was from december
> last year

Thanks.  Your logs look good. FYI. I have a new version of that called 
panelpwr-log.  You should use that rather than rtcwake-log

> Quick comments:
> - The XO charging light was always on with the panel conected, even with
> very low light.

Yes.  This is expected.  Its trying very hard to charge (since the panel 
has voltage) but there just isn't any power.

> - When the battery was full, the XO started doing that buzzing sound,
> like when it works with a low voltage, only this time it was louder than
> in that situation. I'm guessing maybe as the battery wasn't charging the
> panel reached close to open circuit voltage and there was some pretty
> heavy regulation going on?

Sort of.  I disabled the mppt when the battery was full which means that 
the panel will get pulled down and the switcher will start to oscillate. 
  You hear the oscillations.  My latest version does not disable mppt 
when the battery is full.  This should fix that.

> Just from this one, I would say that the firmware worked great! It's a
> pitty I cannot verify with hard numbers the MPPT function.

Thanks for your testing. Can you give q3a62e a spin with the new 
panel-pwr log?  That would be useful info for me.

Richard A. Smith  <richard at>
One Laptop per Child

More information about the Devel mailing list