F14 os3 development image released (XO-1 and XO-1.5)

Bernie Innocenti bernie at codewiz.org
Fri Nov 26 21:43:27 EST 2010

On Fri, 2010-11-26 at 17:49 +0000, Daniel Drake wrote:
> Thanks to everyone who provided feedback on os2. New build is ready:
> http://wiki.laptop.org/go/F14_for_XO (any help on the wiki page appreciated!)
> http://build.laptop.org/F14/os3/
> Notably, suspend/resume is much more reliable and the graphics
> glitches are gone.
> Fixed tickets are:
> #10460 	DCON bad state on first suspend
> #10461 	XO-1.5 messes up serial console during resume
> #10464 	boot partition not mounted on partitioned XO-1
> #10467 	serial console getty unusable after S/R
> #10478 	'About my Computer' shows: :"Wireless Firmware: Not Available"
> #10455 	libertas-related slab corruption
> #10459 	libertas cfg80211 slab corruption
> and:
> Latest F14 updates
> Linux
> UVC + ldusb support
> xorg.conf.d for cleaner X configuration
> Firmware Q3A61 for XO-1.5
> Please test and feed back!

I've tested on an XO-1.5. Here are a few quick bug reports from my first
20 minutes of usage:

== OS ==

 * Despite the initrd optimization and ext4, boot time the same of
   before: 30 seconds (36 seconds on the first boot, due to ssh keys)

 * Graphics seem a lot more fluid on the XO-1.5. Not sure why,
   I like it.

 * AC plug/unplug events don't have any effect on the battery
   frame icon.

 * Automatic power management seem to have improved a lot and is
   almost unnoticeable. However, can't we disable it while the
   laptop is on AC?

== Sugar ==

 * The spiral view gives an initial impression of using something
   completely new, yet familiar.

 * Spurious password prompts at boot. This has been broken in 0.90
   for a couple of months now. Is anyone working on this bug?

 * This is not a regression, but I just noticed that there's no way
   to connect to a hidden network from Sugar. A possible workaround is
   connecting from Gnome and then switching back to Sugar.

 * The Read activity shouldn't appear in the favorite view.

== Activities ==

 * The Record UI is still broken (tsk tsk :-). Seriously, is anyone
   working on the UI rewrite?

 * The Wikipedia activity fails to start. I think it also failed in
   Dextrose, until we merged a small backwards compatibility fix in

 * TamTamMini, TamTamEdit and TamTamSynth fail to start

 * The Help activity is pretty outdated, not localized and generally
   not very useful. It also asks to save to the journal on exit.
   I would recommend removing it until someone improves it.

 * The cursor in Write stops flashing after 2-3 seconds. It does not
   seem to be related with automatic PM.

 * Browse has the 0x0 buttons problem. We fixed it in Dextrose by
   disabling sugar-settings-manager. We also tried to fix the actual
   bug in our XSETTINGS implementation (ask jasg for details).

 * Text in the Terminal is too big. We have a hack to fix this
   in Dextrose which consists in dropping a configuration file
   in ~/.sugar/default/terminalrc at build time.

My overall impression of F14-S0.90 is very positive. I'm sure it won't
take too long before it surpasses the F11 builds in terms of usability
and stability.

Good job!

   // Bernie Innocenti - http://codewiz.org/
 \X/  Sugar Labs       - http://sugarlabs.org/

More information about the Devel mailing list