XO-1.5 audio input DC mode

Gonzalo Odiard gonzalo at laptop.org
Thu Nov 25 00:54:33 EST 2010

I see a problem recording sound in the Distance activity, but I don't
know if it is related.
You can see more information in OLPC #10122 http://dev.laptop.org/ticket/10122
The sound was recorded with the internal mic, at the start there are a
negative max
and a curve before you can get values to process


On Wed, Nov 24, 2010 at 11:41 AM, Richard A. Smith <richard at laptop.org> wrote:
> On 11/24/2010 06:52 AM, Sascha Silbe wrote:
>> 2. The voltage I see with bias off is probably generated internally by
>>     the codec chip. I don't think the chip designers envisioned it to be
>>     used without a decoupling capacitor. I've been told the (non-public)
>>     data sheet is rather sparse on details about the analog part of the
>>     chip, so this is a good an understanding as we're going to get.
> The datasheet is sparse yes but we have technical contacts at conexant
> who can answer your questions.  The DC input mode was part of our early
> discussions with them and its supposed to work at least as good as the
> last chip did.  I specifically remember asking them about this and
> telling them it was something to test in our early reviews of the
> hardware.   It should work.  If not then we need to know why so we can
> prevent it from happening on the 1.75.
> If you will frame up your questions with good detailed descriptions on
> how to duplicate the problems you are having I'll see that it makes it
> to conexant for testing and feedback and make sure they have the proper
> hardware to test it on.
> --
> Richard A. Smith  <richard at laptop.org>
> One Laptop per Child
> _______________________________________________
> Devel mailing list
> Devel at lists.laptop.org
> http://lists.laptop.org/listinfo/devel

More information about the Devel mailing list