Adobe Flash 10.1 + AIR 2.0 on the XO

Mikus Grinbergs mikus at bga.com
Wed Mar 24 22:05:43 EDT 2010


> I can tell you that youtube is well within reach of both the XO-1 and 1.5,
> currently (or at least up to build 114), it was running better and faster on
> the XO-1 rather than on the XO 1.5 due to the presence of Xv support. The
> problem is that I can only have decent performance by not using Flash but by
> using the Firefox Greasemonkey add-on and the HQTube script:
> http://userscripts.org/scripts/show/63509

I tried to do what you describe -- but that isn't my concept of watching
YouTube.  The way I ran it, the HQTube script appeared to download the
entire clip before trying to play that clip -- I prefer to start seeing
a YouTube clip within seconds of clicking on the internet link for it.

Much worse, with the HQTube script installed, an error popup told me the
downloaded clip could not be played because I did not have the Sorenson
Spark codec installed -- Wikipedia says that codec is built-in to Flash,
but I don't know how to acquire it for whatever HQTube tried to execute.


Xv capability now works on both the F11 XO-1.5 and the F11 XO-1 -- but
people posting about Flash claim that "native" Flash needs RGB, whereas
Xv uses YUV -- therefore "native" Flash does not invoke Xv acceleration.


mikus


p.s.  On XO-1.5, latest Flash plugin plus latest Firefox still regularly
gives a "slideshow" for YouTube, but the result is often tolerable.



More information about the Devel mailing list