F11-for-XO1.5 Release 10.1.1 Release Candidate 2

Bert Freudenberg bert at freudenbergs.de
Sun Jun 13 11:32:12 EDT 2010

On 12.06.2010, at 06:46, Chris Ball wrote:

> http://wiki.laptop.org/go/F11_for_1.5
> http://build.laptop.org/10.1.1/os203
> Compressed image size: 705.34mb (+13.94mb since build 202)
> This build is the second RC for the 10.1.1 release; if no new blockers
> appear, it will become the final release after a period of testing.
> Some bugs that we'd like particular help testing:
> * http://dev.laptop.org/ticket/10045 :
>  - Fix loss of audio/video sync in Record activity.  Some instances of
>    sync loss may remain, especially if you're running other activities
>    at the same time as Record; we'd like to hear your feedback.
> * http://dev.laptop.org/ticket/10168 :
>  - Fix "Scratch can freeze up after playing sound".  See reproduction
>    instructions in the ticket.

Installed on my 1.5 after updating the firmware to q3a39.

Typing "boot" in OFW right after "fs-update" froze the machine.

Powered off (long-press on power button) and booted. Let it sit idle for a while in the first-time Sugar screen (name dialog) -> machine froze.

Powered off again, booted. Entered name right away, works.

Tried sound playback in Scratch, it's choppy, many clicks to hear. Suspended fine, resumed playing sound. Recording does not freeze the activity, but has bad quality.

Tried sound playback in Etoys, works fine, no clicks. Suspending with sound playing freezes the activity. Recording still freezes it too. (Both is unsurprising, fix not deployed yet)

Copied ~olpc/Activities/Sratch.activity/vm-sound-ALSA plugin to /usr/lib/squeak/3.10-5/.

After that, in Etoys playback sounds a bit worse, but it's still okay (hard to tell actually). And no freeze after suspend, playing just resumes. So it would be a good idea to use that ALSA plugin for Squeak in general, me thinks.

However, after letting the machine sit idle for a while (even just after booting, still in the Sugar home screen), the whole machine froze. Power LED was still on. Had to power-cycle. Does not happen all the time, but twice already. Maybe it's my machine (one of the first C-test ones)?

- Bert -

More information about the Devel mailing list